Read the docs

ThimPress

Records156All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical23CVSS 9.0–10.0
CVSS high37CVSS 7.0–8.9

Exploited now

ThimPress records in CISA KEV

No ThimPress vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

12 records in Wp Hotel Booking · all components

Priority HIGH 78

The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not escape user input before using it in a SQL statement of a function hooked to admin_init, allowing unauth…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.63711 Published 2023-11-20 Fixed in 2.0.8 CWE-89
Priority MEDIUM 58

The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not ensure that the package to be deleted is a package, allowing any authenticated users, such as subscriber…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00271 Published 2023-11-20 Fixed in 2.0.8 CWE-732
Priority MEDIUM 58

The wp-hotel-booking plugin through 1.10.2 for WordPress allows remote attackers to execute arbitrary code because of an unserialize operation on the thimpress_hotel_booking_1 cookie in load in includes/class-wphb-sessio…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.16017 Published 2021-03-03 No fix listed CWE-502
Priority MEDIUM 57

The WP Hotel Booking plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the update_review() function in all versions up to, and including, 2.1.2.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.17743 Published 2024-10-02 No fix listed CWE-434
Priority MEDIUM 56

The WP Hotel Booking plugin for WordPress is vulnerable to SQL Injection via the 'room_type' parameter of the /wphb/v1/rooms/search-rooms REST API endpoint in all versions up to, and including, 2.1.0 due to insufficient…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.04152 Published 2024-06-20 No fix listed CWE-89
Priority LOW 30

The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check when adding rooms in all versions up to, and including, 2.1.5.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00327 Published 2025-01-17 No fix listed CWE-284
Priority LOW 25

The WP Hotel Booking WordPress plugin before 2.0.8 does not have proper authorisation when deleting a package, allowing Contributor and above roles to delete posts that do no belong to them

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.0052 Published 2023-11-20 Fixed in 2.0.8 CWE-863
Priority LOW 20

The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the hotel_booking_load_order_user AJAX action in all versions up to, and including, 2.1.6.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00369 Published 2025-01-22 No fix listed CWE-862
Priority LOW 20

The WP Hotel Booking plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.10.1.

CVSS 3.1MEDIUM 4.3 Network No auth User interaction EPSS 0.00393 Published 2023-07-12 Fixed in 1.10.2 CWE-352
Open these records in search →