Read the docs

ThimPress

Records156All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical23CVSS 9.0–10.0
CVSS high37CVSS 7.0–8.9

Exploited now

ThimPress records in CISA KEV

No ThimPress vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

156 records

Priority HIGH 84

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_only_fields' parameter of the /wp-json/learnpress/v1/courses REST API endpoint in all versions up to, and including, 4.…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.62882 Published 2024-09-12 No fix listed CWE-89
Priority HIGH 80

The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user supplied parameter and lac…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.51394 Published 2024-01-11 No fix listed CWE-89
Priority HIGH 78

The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not escape user input before using it in a SQL statement of a function hooked to admin_init, allowing unauth…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.63711 Published 2023-11-20 Fixed in 2.0.8 CWE-89
Priority HIGH 75

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to time-based SQL Injection via the ‘term_id’ parameter in versions up to, and including, 4.2.6.5 due to insufficient escaping on the user supplied…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.36925 Published 2024-05-10 No fix listed CWE-89
Priority HIGH 70

The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to rem…

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.02633 Published 2022-10-31 Fixed in 4.1.7.2 CWE-502
Priority MEDIUM 63

The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_fields' parameter of the /wp-json/lp/v1/courses/archive-course REST API endpoint in all versions up to, and including,…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.12056 Published 2024-09-12 No fix listed CWE-89
Priority MEDIUM 60

The LearnPress WordPress plugin before 4.2.5.5 does not sanitise and escape user input before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users s…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00908 Published 2024-01-16 Fixed in 4.2.5.5 CWE-79
Priority MEDIUM 58

The WP Hotel Booking WordPress plugin before 2.0.8 does not have authorisation and CSRF checks, as well as does not ensure that the package to be deleted is a package, allowing any authenticated users, such as subscriber…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00271 Published 2023-11-20 Fixed in 2.0.8 CWE-732
Priority MEDIUM 58

The wp-hotel-booking plugin through 1.10.2 for WordPress allows remote attackers to execute arbitrary code because of an unserialize operation on the thimpress_hotel_booking_1 cookie in load in includes/class-wphb-sessio…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.16017 Published 2021-03-03 No fix listed CWE-502
Priority MEDIUM 57

The WP Hotel Booking plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the update_review() function in all versions up to, and including, 2.1.2.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.17743 Published 2024-10-02 No fix listed CWE-434
Priority MEDIUM 56

The WP Hotel Booking plugin for WordPress is vulnerable to SQL Injection via the 'room_type' parameter of the /wphb/v1/rooms/search-rooms REST API endpoint in all versions up to, and including, 2.1.0 due to insufficient…

CVSS 3.1CRITICAL 10.0 Network No auth No interaction EPSS 0.04152 Published 2024-06-20 No fix listed CWE-89
Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00355 Published 2025-05-15 Fixed in 4.2.7.5.1 CWE-79
Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 4.2.7.5.1 CWE-79
TI-2024-09290 CVE-2024-10010 · GHSA-jx47-v2mx-xmc3

LearnPress < 4.2.7.2 - Admin+ Stored XSS

Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00462 Published 2024-12-12 Fixed in 4.2.7.2 CWE-79
TI-2024-09167 CVE-2024-9881 · GHSA-p9v3-8f7q-wffx

LearnPress < 4.2.7.2 - Admin+ Stored XSS

Priority MEDIUM 55

The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.0038 Published 2024-12-12 Fixed in 4.2.7.2 CWE-79
Priority MEDIUM 54

The LearnPress plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 4.4.10 via deserialization of untrusted input from the 'checkout-email' request parameter during the checkout AJ…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02524 Published 2026-10-17 No fix listed CWE-502
TI-2023-06080 CVE-2023-6634 · GHSA-3jrv-ghj9-h744

LearnPress <= 4.2.5.7 - Command Injection

Priority MEDIUM 54

The LearnPress plugin for WordPress is vulnerable to Command Injection in all versions up to, and including, 4.2.5.7 via the get_content function.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.08614 Published 2024-01-11 No fix listed CWE-88
Priority MEDIUM 49

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in ThimPress BuilderPress builderpress allows PHP Local File Inclusion.This issue affects BuilderPress…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00348 Published 2026-03-19 No fix listed CWE-98
Priority MEDIUM 49

Deserialization of Untrusted Data vulnerability in ThimPress Course Builder course-builder allows Object Injection.This issue affects Course Builder: from n/a through < 3.6.6.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00486 Published 2025-05-29 No fix listed CWE-502
Priority MEDIUM 49

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ThimPress WP Pipes allows SQL Injection.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00479 Published 2025-07-16 No fix listed CWE-89
Priority MEDIUM 49

Deserialization of Untrusted Data vulnerability in ThimPress FundPress fundpress allows Object Injection.This issue affects FundPress: from n/a through <= 2.0.6.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00504 Published 2025-01-27 No fix listed CWE-502
Load more
Open these records in search →