Priority HIGH 84
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_only_fields' parameter of the /wp-json/learnpress/v1/courses REST API endpoint in all versions up to, and including, 4.…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.62882 · Published 2024-09-12 · No fix listed CWE-89
Priority HIGH 80
The LearnPress plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order_by’ parameter in all versions up to, and including, 4.2.5.7 due to insufficient escaping on the user supplied parameter and lac…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.51394 · Published 2024-01-11 · No fix listed CWE-89
Priority HIGH 75
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to time-based SQL Injection via the ‘term_id’ parameter in versions up to, and including, 4.2.6.5 due to insufficient escaping on the user supplied…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.36925 · Published 2024-05-10 · No fix listed CWE-89
Priority HIGH 71
Missing Authorization vulnerability in ThimPress LearnPress.This issue affects LearnPress: from n/a through 4.2.3.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0051 · Published 2024-06-19 · No fix listed CWE-862
Priority HIGH 70
The LearnPress WordPress plugin before 4.1.7.2 unserialises user input in a REST API endpoint available to unauthenticated users, which could lead to PHP Object Injection when a suitable gadget is present, leadint to rem…
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.02633 · Published 2022-10-31 · Fixed in 4.1.7.2 CWE-502
Priority HIGH 69
LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.49231 · Published 2020-04-30 · No fix listed CWE-89
Priority MEDIUM 63
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to SQL Injection via the 'c_fields' parameter of the /wp-json/lp/v1/courses/archive-course REST API endpoint in all versions up to, and including,…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.12056 · Published 2024-09-12 · No fix listed CWE-89
Priority MEDIUM 60
The LearnPress WordPress plugin before 4.2.5.5 does not sanitise and escape user input before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users s…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00908 · Published 2024-01-16 · Fixed in 4.2.5.5 CWE-79
Priority MEDIUM 56
Local File Inclusion vulnerability in LearnPress – WordPress LMS Plugin <= 4.1.7.3.2 versions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05159 · Published 2023-01-24 · No fix listed CWE-434
Priority MEDIUM 56
SQL Injection vulnerability in LearnPress – WordPress LMS Plugin <= 4.1.7.3.2 versions.
CVSS 3.1CRITICAL 9.9· Network · No auth · No interaction · EPSS 0.0435 · Published 2023-01-24 · No fix listed CWE-89
Priority MEDIUM 55
The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00355 · Published 2025-05-15 · Fixed in 4.2.7.5.1 CWE-79
Priority MEDIUM 55
The LearnPress WordPress plugin before 4.2.7.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00326 · Published 2025-05-15 · Fixed in 4.2.7.5.1 CWE-79
Priority MEDIUM 55
The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00462 · Published 2024-12-12 · Fixed in 4.2.7.2 CWE-79
Priority MEDIUM 55
The LearnPress WordPress plugin before 4.2.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilter…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.0038 · Published 2024-12-12 · Fixed in 4.2.7.2 CWE-79
Priority MEDIUM 54
The LearnPress plugin for WordPress is vulnerable to Command Injection in all versions up to, and including, 4.2.5.7 via the get_content function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.08614 · Published 2024-01-11 · No fix listed CWE-88
Priority MEDIUM 45
The LearnPress WordPress plugin before 4.1.4 does not sanitise, validate and escape the id parameter before using it in SQL statements when duplicating course/lesson/quiz/question, leading to SQL Injections issues
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01627 · Published 2021-12-13 · Fixed in 4.1.4 CWE-89
Priority MEDIUM 42
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.2.6.8.2 via the 'render_content_block_template' function.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00814 · Published 2024-07-25 · No fix listed CWE-98
Priority MEDIUM 42
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_post_materials' function in versions up to, and including, 4.2.6.5.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01025 · Published 2024-05-09 · No fix listed CWE-434
Priority MEDIUM 42
Missing Authorization vulnerability in ThimPress LearnPress.This issue affects LearnPress: from n/a through 4.2.3.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00441 · Published 2024-06-19 · No fix listed CWE-862
Priority MEDIUM 41
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to time-based SQL Injection via the 'order' parameter in all versions up to, and including, 4.2.6.9.3 due to insufficient escaping on the user supp…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00618 · Published 2024-08-08 · No fix listed CWE-89
Priority MEDIUM 41
SQL Injection (SQLi) vulnerability in LearnPress – WordPress LMS Plugin <= 4.1.7.3.2 versions.
CVSS 3.1CRITICAL 9.1· Network · Low privileges · No interaction · EPSS 0.01025 · Published 2023-01-24 · No fix listed CWE-89
Priority MEDIUM 41
The LearnPress plugin before 3.2.6.9 for WordPress allows remote attackers to escalate the privileges of any user to LP Instructor via the accept-to-be-teacher action parameter.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.03209 · Published 2021-07-27 · No fix listed CWE-862
Priority MEDIUM 40
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.0.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00273 · Published 2024-04-05 · No fix listed CWE-352
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in ThimPress LearnPress.This issue affects LearnPress: from n/a through 4.2.6.8.2.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00196 · Published 2024-08-26 · No fix listed CWE-352
Priority LOW 34
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the _id value in all versions up to, and including, 4.2.6.4 due to insufficient input sanitization and output es…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.0032 · Published 2024-04-19 · No fix listed CWE-79
Load more