Read the docs

varnish-software

Records18All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

varnish-software records in CISA KEV

No varnish-software vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

6 records in Varnish Enterprise · all components

Priority MEDIUM 41

Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked req.url scenarios, mishandle URLs with a path of / for HTTP/1.1, potentially leading to cache poisoning or authentication bypass.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0021 Published 2026-03-27 Partial fix · 6.0.17 LTS, 8.0.1 CWE-180
Priority LOW 36

libvmod-digest before 1.0.3, as used in Varnish Enterprise 6.0.x before 6.0.11r5, has an out-of-bounds memory access during base64 decoding, leading to both authentication bypass and information disclosure; however, the…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00595 Published 2023-08-23 No fix listed CWE-119
Priority LOW 33

Varnish Enterprise before 6.0.13r13 allows remote attackers to obtain sensitive information via an out-of-bounds read for range requests on ephemeral MSE4 stevedore objects.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00351 Published 2025-03-21 Fixed in 6.0.13r13 CWE-125
Open these records in search →