Priority HIGH 76
A cross-site scripting (XSS) vulnerability in the Settings section of WonderCMS v3.4.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the WEBSITE TITLE parameter under the M…
CVSS 3.1CRITICAL 9.6· Network · No auth · User interaction · EPSS 0.00711 · Published 2024-04-17 · No fix listed CWE-79
Priority HIGH 72
WonderCMS 4.3.2 contains a cross-site scripting vulnerability that allows attackers to inject malicious JavaScript through the module installation endpoint.
CVSS 4.0HIGH 8.6· Network · No auth · User interaction · EPSS 0.00426 · Published 2025-12-12 · No fix listed CWE-79
Priority HIGH 72
A Server-Side Request Forgery (SSRF) in the installUpdateThemePluginAction function of WonderCMS v3.1.3 allows attackers to force the application to make arbitrary requests via injection of crafted URLs into the installT…
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00585 · Published 2024-03-05 · No fix listed CWE-918
Priority HIGH 71
A server-side request forgery (SSRF) vulnerability in the addCustomThemePluginRepository function in index.php in WonderCMS 3.1.3 allows remote attackers to execute arbitrary code via a crafted URL to the theme/plugin in…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.45221 · Published 2021-04-20 · No fix listed CWE-918
Priority MEDIUM 64
WonderCMS 3.5.0 is vulnerable to Server-Side Request Forgery (SSRF) in the custom module installation functionality.
CVSS 3.1MEDIUM 6.5· Network · High privileges · No interaction · EPSS 0.00409 · Published 2025-09-17 · No fix listed CWE-918
Priority MEDIUM 64
A Server-Side Request Forgery (SSRF) in the Plugins Page of WonderCMS v3.4.3 allows attackers to force the application to make arbitrary requests via injection of crafted URLs into the pluginThemeUrl parameter.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00186 · Published 2024-07-30 · No fix listed CWE-352
Priority MEDIUM 64
A remote code execution vulnerability in the installUpdateThemePluginAction function in index.php in WonderCMS 3.1.3, allows remote attackers to upload a custom plugin which can contain arbitrary code and obtain a webshe…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.26912 · Published 2021-04-20 · No fix listed CWE-78
Priority MEDIUM 62
A cross-site scripting (XSS) vulnerability in the Settings section of WonderCMS v3.4.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the PAGE DESCRIPTION parameter under th…
CVSS 3.1MEDIUM 5.9· Local · No auth · No interaction · EPSS 0.00316 · Published 2024-04-17 · No fix listed CWE-79
Priority MEDIUM 62
A Server-Side Request Forgery (SSRF) in the getFileFromRepo function of WonderCMS v3.1.3 allows attackers to force the application to make arbitrary requests via injection of crafted URLs into the pluginThemeUrl paramete…
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00417 · Published 2024-03-05 · No fix listed CWE-918
Priority MEDIUM 60
An arbitrary file upload vulnerability in the uploadFileAction() function of WonderCMS v3.4.3 allows attackers to execute arbitrary code via a crafted SVG file.
CVSS 3.1MEDIUM 5.4· Physical · Low privileges · No interaction · EPSS 0.00359 · Published 2024-07-30 · No fix listed CWE-94
Priority MEDIUM 60
Multiple cross-site scripting (XSS) vulnerabilities in the HOW TO page of WonderCMS v3.4.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into any of the parameters.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00404 · Published 2024-04-17 · No fix listed CWE-79
Priority MEDIUM 60
Cross Site Scripting vulnerability in Wonder CMS v.3.2.0 thru v.3.4.2 allows a remote attacker to execute arbitrary code via a crafted script uploaded to the installModule component.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.54305 · Published 2023-11-07 · No fix listed CWE-79
Priority MEDIUM 58
A cross-site scripting (XSS) vulnerability in the Settings section of WonderCMS v3.4.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the SITE LANGUAGE CONFIG parameter unde…
CVSS 3.1MEDIUM 5.5· Network · Low privileges · User interaction · EPSS 0.00402 · Published 2024-04-17 · No fix listed CWE-79
Priority MEDIUM 56
A vulnerability, which was classified as critical, has been found in WonderCMS 3.5.0.
CVSS 4.0MEDIUM 5.1· Network · High privileges · No interaction · EPSS 0.00589 · Published 2025-04-02 · No fix listed CWE-284
Priority MEDIUM 54
A cross-site scripting (XSS) vulnerability in the Settings section of WonderCMS v3.4.3 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the MENU parameter under the Menu modul…
CVSS 3.1MEDIUM 4.6· Network · Low privileges · User interaction · EPSS 0.00454 · Published 2024-04-17 · No fix listed CWE-80
Priority MEDIUM 48
In WonderCMS 2.3.1, the upload functionality accepts random application extensions and leads to malicious File Upload.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.07299 · Published 2018-01-26 · No fix listed CWE-434
Priority MEDIUM 46
Directory traversal vulnerability in index.php in Wonder CMS 2014 allows remote attackers to include and execute arbitrary local files via a crafted theme.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02012 · Published 2017-03-17 · No fix listed CWE-22
Priority MEDIUM 45
PHP remote file inclusion vulnerability in editInplace.php in Wonder CMS 2014 allows remote attackers to execute arbitrary PHP code via a URL in the hook parameter.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0148 · Published 2017-03-17 · No fix listed CWE-20
Priority MEDIUM 44
WonderCMS 2.3.1 is vulnerable to an HTTP Host header injection attack.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.08045 · Published 2018-01-26 · No fix listed CWE-74
Priority MEDIUM 41
An issue was discovered in WonderCMS before 2.5.2.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.01632 · Published 2018-07-18 · No fix listed CWE-384
Priority LOW 39
WonderCMS before 2.0.3 has CSRF because of lack of a token in an unspecified context.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.00565 · Published 2017-04-21 · No fix listed CWE-352
Priority LOW 36
Wonder CMS 2014 allows remote attackers to obtain sensitive information by viewing /files/password, which reveals the unsalted MD5 hashed password.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01462 · Published 2017-03-17 · No fix listed CWE-200
Priority LOW 33
Directory traversal vulnerability in WonderCMS 2.6.0 and earlier allows remote attackers to delete arbitrary files via unspecified vectors.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.01862 · Published 2019-09-12 · No fix listed CWE-22
Priority LOW 30
In WonderCMS 2.3.1, the application's input fields accept arbitrary user input resulting in execution of malicious JavaScript.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01197 · Published 2018-01-26 · No fix listed CWE-79
Priority LOW 29
Cross-site scripting (XSS) vulnerability in Wonder CMS 2014 allows remote attackers to inject arbitrary web script or HTML.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00777 · Published 2017-03-17 · No fix listed CWE-79
Load more