Read the docs

wpsoul

Records32All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high4CVSS 7.0–8.9

Exploited now

wpsoul records in CISA KEV

No wpsoul vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

32 records

TI-2023-00362 CVE-2023-0378 · GHSA-hqp7-82rq-x5hr

Greenshift < 5.0 - Contributor+ Stored XSS

Priority HIGH 65

The Greenshift WordPress plugin before 5.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and…

CVSS 3.1MEDIUM 6.8 Network High privileges User interaction EPSS 0.00627 Published 2023-02-21 Fixed in 5.0
Priority MEDIUM 45

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the gspb_make_proxy_api_request() function in versions 11.4 to 11.4.5…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02566 Published 2025-04-22 No fix listed CWE-434
Priority MEDIUM 42

Incorrect Authorization vulnerability in wpsoul Greenshift greenshift-animation-and-page-builder-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Greenshift: from n/a thro…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00295 Published 2024-10-30 No fix listed CWE-863
Priority LOW 38

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Wpsoul Greenshift Woocommerce Addon allows SQL Injection.This issue affects Greenshift Woocommerce Addon: from n/a bef…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00441 Published 2024-08-29 Fixed in 1.9.8 CWE-89
Priority LOW 38

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Wpsoul Greenshift Query and Meta Addon allows SQL Injection.This issue affects Greenshift Query and Meta Addon: from n…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00441 Published 2024-08-29 Fixed in 3.9.2 CWE-89
Priority LOW 36

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation on the 'gspb_save_files' function in versions up to, and including, 7.6.…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01274 Published 2024-01-11 No fix listed CWE-434
Priority LOW 30

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 12.8.3 via the automated Settings Backup stored in a publicly…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00272 Published 2026-03-05 No fix listed CWE-200
Priority LOW 29

The GreenShift - Animation and Page Builder Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 12.8.9 This is due to insufficient input sanitization and output esca…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0042 Published 2026-04-11 No fix listed CWE-79
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpsoul Greenshift greenshift-animation-and-page-builder-blocks allows Stored XSS.This issue affects Greenshift: from n…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00374 Published 2025-03-27 No fix listed CWE-79
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpsoul Greenshift greenshift-animation-and-page-builder-blocks allows Stored XSS.This issue affects Greenshift: from n…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00288 Published 2025-02-25 No fix listed CWE-79
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpsoul Greenshift greenshift-animation-and-page-builder-blocks allows Stored XSS.This issue affects Greenshift: from n…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00295 Published 2024-09-17 No fix listed CWE-79
Priority LOW 28

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `_gspb_post_css` post meta value and the `dynamicAttributes` block attribute in all versions up…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00224 Published 2026-03-05 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpsoul Greenshift greenshift-animation-and-page-builder-blocks allows DOM-Based XSS.This issue affects Greenshift: fro…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00269 Published 2025-06-06 No fix listed CWE-79
Priority LOW 28

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Chart Data attributes in all versions up to, and including, 12.2.7 due to insufficient input sa…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00193 Published 2025-11-04 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpsoul GreenCon greencon allows Stored XSS.This issue affects GreenCon: from n/a through <= 1.0.1.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00266 Published 2024-11-19 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wpsoul Greenshift – animation and page builder blocks allows Stored XSS.This issue affects Greenshift – animati…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00261 Published 2024-06-19 No fix listed CWE-79
Priority LOW 28

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Authenticated (Subscriber+) Server-Side Request Forgery and Stored Cross Site Scripting in all versions up to, and including, 9.0.0…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00292 Published 2025-01-09 No fix listed CWE-862
Priority LOW 28

The Freemius SDK, as used by hundreds of WordPress plugin and theme developers, was vulnerable to Cross-Site Request Forgery and Information disclosure due to missing capability checks and nonce protection on the _get_de…

CVSS 3.1MEDIUM 6.3 Network Low privileges No interaction EPSS 0.00442 Published 2024-10-16 Fixed in 2.0.2, 1.9.8 +273 CWE-862
Priority LOW 27

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via '{{GET:}}' Dynamic Placeholder in all versions up to, and including, 13.2.0 due to insufficient…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00211 Published 2026-10-02 No fix listed CWE-79
Priority LOW 26

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wpsoul Table Maker allows Stored XSS.This issue affects Table Maker: from n/a through 1.9.1.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00338 Published 2024-05-08 No fix listed CWE-79
Priority LOW 24

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 13.2.2 via the 'img (or any key the publisher references in {{…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00255 Published 2026-11-07 No fix listed CWE-200
Load more
Open these records in search →