Greenshift < 5.0 - Contributor+ Stored XSS
Priority HIGH 65Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Greenshift WordPress plugin before 5.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00627 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Greenshift (Unknown): 5.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Greenshift | before 5.0 | 5.0 | Patch available | CNA |
- Greenshift VendorUnknown Affected before 5.0 Fixed in 5.0 Patch available CNA
Remediation
- Fix · CNA Greenshift (Unknown) Fixed in 5.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0378
- 2026-10-03 Alias added: GHSA-hqp7-82rq-x5hr
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More wpsoul Greenshift vulnerabilities
- TI-2022-04253 Greenshift – animation and page builder blocks < 4.8.9 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2023-06082 Greenshift – animation and page builder blocks <= 7.6.2 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2025-22143 WordPress Greenshift plugin <= 11.0.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-29594 WordPress Greenshift plugin <= 9.3.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-23634 WordPress Greenshift – animation and page builder blocks plugin <= 8.8.9.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2023-08882 WordPress Greenshift – animation and page builder blocks Plugin <= 4.9.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-0378 · CVE Program
- CVE-2023-0378 · NVD
- FIRST EPSS
- GHSA-hqp7-82rq-x5hr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences