Read the docs
TI-2022-04253 Aliases CVE-2022-4653GHSA-h8wf-2g76-x8c2

Greenshift – animation and page builder blocks < 4.8.9 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Greenshift WordPress plugin before 4.8.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00404 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Greenshift (Unknown): 4.8.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownGreenshiftbefore 4.8.94.8.9Patch availableCNA
  • Greenshift VendorUnknown Affected before 4.8.9 Fixed in 4.8.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpsoul:greenshift:*:*:*:*:*:wordpress:*:*before 4.8.9Vulnerablewpsoul
  • cpe:2.3:a:wpsoul:greenshift:*:*:*:*:*:wordpress:*:* Versions before 4.8.9 Vulnerable ·wpsoul

Remediation

  • Fix · CNA Greenshift (Unknown) Fixed in 4.8.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4653
  2. 2026-10-03 Alias added: GHSA-h8wf-2g76-x8c2

References

  • TI-2023-00362 Greenshift < 5.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
  • TI-2023-06082 Greenshift – animation and page builder blocks <= 7.6.2 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
  • TI-2025-22143 WordPress Greenshift plugin <= 11.0.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-29594 WordPress Greenshift plugin <= 9.3.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-23634 WordPress Greenshift – animation and page builder blocks plugin <= 8.8.9.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2023-08882 WordPress Greenshift – animation and page builder blocks Plugin <= 4.9.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources