Read the docs

wpxpo

Records47All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high16CVSS 7.0–8.9

Exploited now

wpxpo records in CISA KEV

No wpxpo vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

47 records

Priority HIGH 67

The Post Grid Gutenberg Blocks and WordPress Blog Plugin – PostX plugin for WordPress is vulnerable to unauthorized plugin installation/activation due to a missing capability check on the 'install_required_plugin_callbac…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.39069 Published 2024-11-16 No fix listed CWE-862
TI-2024-04008 CVE-2024-4305 · GHSA-97gr-9g44-39q4

PostX < 4.1.0 - Contributor+ Stored XSS

Priority MEDIUM 63

The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.1.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which cou…

CVSS 3.1MEDIUM 6.8 Network Low privileges User interaction EPSS 0.0043 Published 2024-06-17 Fixed in 4.1.0 CWE-79
Priority MEDIUM 60

The PostX WordPress plugin before 3.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00493 Published 2023-08-30 Fixed in 3.0.6
Priority MEDIUM 43

Deserialization of Untrusted Data vulnerability in wpxpo ProductX – WooCommerce Builder & Gutenberg WooCommerce Blocks.This issue affects ProductX – WooCommerce Builder & Gutenberg WooCommerce Blocks: from n/a through 3.…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00519 Published 2024-02-12 No fix listed CWE-502
Priority MEDIUM 40

The WowRevenue plugin for WordPress is vulnerable to unauthorized plugin installation due to a missing capability check in the 'Notice::install_activate_plugin' function in all versions up to, and including, 2.1.3.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00429 Published 2026-02-16 No fix listed CWE-862
Priority MEDIUM 40

The WowOptin: Next-Gen Popup Maker – Create Stunning Popups and Optins for Lead Generation plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation due to a missing capability check on the 'instal…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00321 Published 2026-03-05 No fix listed CWE-862
Priority LOW 39

The WowStore – Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the ‘search’ parameter in all versions up to, and including, 4.4.3 due to insufficient escaping on the…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00323 Published 2026-03-17 No fix listed CWE-89
Priority LOW 39

Missing Authorization vulnerability in WPXPO PostX ultimate-post allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PostX: from n/a through <= 5.0.3.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00341 Published 2026-01-22 No fix listed CWE-862
Priority LOW 39

The Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the '/ultp/v2/get_dynamic_content/' REST AP…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00322 Published 2025-12-21 No fix listed CWE-862
Priority LOW 38

The Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 5.0.8 via the `/ultp/v3/starter_dummy_post…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00345 Published 2026-03-04 No fix listed CWE-918
Priority LOW 38

Missing Authorization vulnerability in WPXPO PostX ultimate-post allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PostX: from n/a through <= 3.2.3.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00336 Published 2024-06-09 No fix listed CWE-862
Priority LOW 35

Missing Authorization vulnerability in WPXPO WowAddons product-addons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WowAddons: from n/a through <= 1.6.8.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00332 Published 2026-07-13 No fix listed CWE-862
Priority LOW 34

Incorrect Privilege Assignment vulnerability in WPXPO PostX ultimate-post allows Privilege Escalation.This issue affects PostX: from n/a through <= 4.1.35.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00404 Published 2025-12-18 No fix listed CWE-266
Priority LOW 31

The Post Grid Gutenberg Blocks – PostX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via display_name User Field in all versions up to, and including, 5.1.0 due to insufficient input sanitization and…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00236 Published 2026-10-10 No fix listed CWE-79
Priority LOW 31

Missing Authorization vulnerability in WPXPO PostX ultimate-post allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PostX: from n/a through <= 4.1.36.

CVSS 3.1HIGH 7.1 Network Low privileges No interaction EPSS 0.00251 Published 2025-12-18 No fix listed CWE-862
Priority LOW 30

The Post Grid Gutenberg Blocks for News, Magazines, Blog Websites – PostX plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ultp_shareCount_callback() functi…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00283 Published 2026-04-16 No fix listed CWE-862
Priority LOW 30

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in WPXPO PostX ultimate-post allows Retrieve Embedded Sensitive Data.This issue affects PostX: from n/a through <= 5.0.3.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00234 Published 2025-12-24 No fix listed CWE-497
Priority LOW 30

The PostX – Gutenberg Blocks for Post Grid WordPress plugin before 2.4.10 performs incorrect checks before allowing any logged in user to perform some ajax based requests, allowing any user to modify, delete or add ultp_…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00716 Published 2021-09-27 Fixed in 2.4.10 CWE-863
Load more
Open these records in search →