Read the docs
TI-2024-04008 Aliases CVE-2024-4305GHSA-97gr-9g44-39q4

PostX < 4.1.0 - Contributor+ Stored XSS

Priority MEDIUM 63CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.1.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0043 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Post Grid Gutenberg Blocks and WordPress Blog Plugin (Unknown): 4.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPost Grid Gutenberg Blocks and WordPress Blog Plugin before 4.1.04.1.0Patch availableCNA
  • Post Grid Gutenberg Blocks and WordPress Blog Plugin VendorUnknown Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpxpo:postx:*:*:*:*:*:wordpress:*:*before 4.1.0Vulnerablewpxpo
  • cpe:2.3:a:wpxpo:postx:*:*:*:*:*:wordpress:*:* Versions before 4.1.0 Vulnerable ·wpxpo

Remediation

  • Fix · CNA Post Grid Gutenberg Blocks and WordPress Blog Plugin (Unknown) Fixed in 4.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-4305
  2. 2026-10-03 Alias added: GHSA-97gr-9g44-39q4

References

  • TI-2024-09942 PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation CVSS 3.1HIGH 8.8
  • TI-2023-03707 PostX - Gutenberg Post Grid Blocks < 3.0.6 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2024-20622 WordPress PostX plugin <= 3.2.3 - Author+ Post/Page Duplication vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-18248 WordPress PostX – Gutenberg Blocks for Post Grid Plugin <= 2.9.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-33876 WordPress PostX plugin <= 4.1.12 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-03037 PostX < 4.0.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4

Sources