Read the docs
TI-2023-03707 Aliases CVE-2023-3992GHSA-xpfj-gvqx-gmx2

PostX - Gutenberg Post Grid Blocks < 3.0.6 - Reflected Cross-Site Scripting

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The PostX WordPress plugin before 3.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00493 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PostX (Unknown): 3.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPostXbefore 3.0.63.0.6Patch availableCNA
  • PostX VendorUnknown Affected before 3.0.6 Fixed in 3.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpxpo:postx:*:*:*:*:*:wordpress:*:*before 3.0.6Vulnerablewpxpo
  • cpe:2.3:a:wpxpo:postx:*:*:*:*:*:wordpress:*:* Versions before 3.0.6 Vulnerable ·wpxpo

Remediation

  • Fix · CNA PostX (Unknown) Fixed in 3.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-3992
  2. 2026-10-03 Alias added: GHSA-xpfj-gvqx-gmx2

References

  • TI-2024-09942 PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation CVSS 3.1HIGH 8.8
  • TI-2024-04008 PostX < 4.1.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
  • TI-2024-20622 WordPress PostX plugin <= 3.2.3 - Author+ Post/Page Duplication vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-18248 WordPress PostX – Gutenberg Blocks for Post Grid Plugin <= 2.9.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-33876 WordPress PostX plugin <= 4.1.12 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-03037 PostX < 4.0.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4

Sources