Read the docs
TI-2006-04754 Aliases CVE-2006-4936GHSA-h9w8-4376-j344

Moodle before 1.6.2 does not properly validate the module instance id when creating a…

Priority MEDIUM 46CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Complete · Complete · Complete
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

Moodle before 1.6.2 does not properly validate the module instance id when creating a course module object, which has unspecified impact and remote attack vectors.

Why it matters now

EPSS 0.01506 74th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 1.6.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)before 1.6.21.6.2Patch availableGHSA-h9w8-4376-j344
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected before 1.6.2 Fixed in 1.6.2 Patch available GHSA-h9w8-4376-j344

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 1.6.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.6.0:*:*:*:*:*:*:*1.6.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 1.6.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-h9w8-4376-j344 moodle/moodle (Packagist) Fixed in 1.6.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2006-4936
  2. 2026-10-03 Alias added: GHSA-h9w8-4376-j344

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources