Read the docs
TI-2022-16116 Aliases CVE-2022-35650GHSA-pgm5-cr62-prxq

Path traversal in Moodle

Priority HIGH 65CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.

Why it matters now

EPSS 0.53652 99th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.15, 3.11.8, 4.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—MoodleFixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15—No fix listedCNA
—moodle/moodle (Packagist)3.9 to before 3.9.153.9.15Patch availableGHSA-pgm5-cr62-prxq
—moodle/moodle (Packagist)3.11 to before 3.11.83.11.8Patch availableGHSA-pgm5-cr62-prxq
—moodle/moodle (Packagist)4.0 to before 4.0.24.0.2Patch availableGHSA-pgm5-cr62-prxq
  • Moodle Vendor— Affected Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.9 to before 3.9.15 Fixed in 3.9.15 Patch available GHSA-pgm5-cr62-prxq
  • moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.8 Fixed in 3.11.8 Patch available GHSA-pgm5-cr62-prxq
  • moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-pgm5-cr62-prxq

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*35VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.15; 3.11.0 to before 3.11.8; 4.0.0 to before 4.0.2 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-pgm5-cr62-prxq moodle/moodle (Packagist) Fixed in 3.9.15 Advisory →
  • Fix · GHSA-pgm5-cr62-prxq moodle/moodle (Packagist) Fixed in 3.11.8 Advisory →
  • Fix · GHSA-pgm5-cr62-prxq moodle/moodle (Packagist) Fixed in 4.0.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35650
  2. 2026-10-03 Alias added: GHSA-pgm5-cr62-prxq
  3. 2026-10-12 Priority changed: MEDIUM → HIGH
  4. 2026-11-06 EPSS moved to the 99th percentile and above

References

Sources