Qemu 0.9.1 and earlier does not perform range checks for block device read or write…
Priority LOW 22CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Complete · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-264.
Summary
Qemu 0.9.1 and earlier does not perform range checks for block device read or write requests, which allows guest host users with root privileges to access arbitrary memory and escape the virtual machine.
Why it matters now
EPSS 0.00369 30th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 29
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:0.1.0:*:*:*:*:*:*:* | 0.1.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.1:*:*:*:*:*:*:* | 0.1.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.2:*:*:*:*:*:*:* | 0.1.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.3:*:*:*:*:*:*:* | 0.1.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.4:*:*:*:*:*:*:* | 0.1.4 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.5:*:*:*:*:*:*:* | 0.1.5 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.6:*:*:*:*:*:*:* | 0.1.6 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.2.0:*:*:*:*:*:*:* | 0.2.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.3.0:*:*:*:*:*:*:* | 0.3.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.4.0:*:*:*:*:*:*:* | 0.4.0 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:0.1.0:*:*:*:*:*:*:* Versions 0.1.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.1:*:*:*:*:*:*:* Versions 0.1.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.2:*:*:*:*:*:*:* Versions 0.1.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.3:*:*:*:*:*:*:* Versions 0.1.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.4:*:*:*:*:*:*:* Versions 0.1.4 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.5:*:*:*:*:*:*:* Versions 0.1.5 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.6:*:*:*:*:*:*:* Versions 0.1.6 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.2.0:*:*:*:*:*:*:* Versions 0.2.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.3.0:*:*:*:*:*:*:* Versions 0.3.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.4.0:*:*:*:*:*:*:* Versions 0.4.0 Vulnerable ·QEMU
Show 19 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:0.4.1:*:*:*:*:*:*:* | 0.4.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.4.2:*:*:*:*:*:*:* | 0.4.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.4.3:*:*:*:*:*:*:* | 0.4.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.0:*:*:*:*:*:*:* | 0.5.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.1:*:*:*:*:*:*:* | 0.5.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.2:*:*:*:*:*:*:* | 0.5.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.3:*:*:*:*:*:*:* | 0.5.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.4:*:*:*:*:*:*:* | 0.5.4 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.5.5:*:*:*:*:*:*:* | 0.5.5 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.6.0:*:*:*:*:*:*:* | 0.6.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.6.1:*:*:*:*:*:*:* | 0.6.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.7.0:*:*:*:*:*:*:* | 0.7.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.7.1:*:*:*:*:*:*:* | 0.7.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.7.2:*:*:*:*:*:*:* | 0.7.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.8.0:*:*:*:*:*:*:* | 0.8.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.8.1:*:*:*:*:*:*:* | 0.8.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.8.2:*:*:*:*:*:*:* | 0.8.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.9.0:*:*:*:*:*:*:* | 0.9.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.9.1:*:*:*:*:*:*:* | 0.9.1 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:0.4.1:*:*:*:*:*:*:* Versions 0.4.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.4.2:*:*:*:*:*:*:* Versions 0.4.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.4.3:*:*:*:*:*:*:* Versions 0.4.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.0:*:*:*:*:*:*:* Versions 0.5.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.1:*:*:*:*:*:*:* Versions 0.5.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.2:*:*:*:*:*:*:* Versions 0.5.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.3:*:*:*:*:*:*:* Versions 0.5.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.4:*:*:*:*:*:*:* Versions 0.5.4 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.5.5:*:*:*:*:*:*:* Versions 0.5.5 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.6.0:*:*:*:*:*:*:* Versions 0.6.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.6.1:*:*:*:*:*:*:* Versions 0.6.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.7.0:*:*:*:*:*:*:* Versions 0.7.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.7.1:*:*:*:*:*:*:* Versions 0.7.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.7.2:*:*:*:*:*:*:* Versions 0.7.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.8.0:*:*:*:*:*:*:* Versions 0.8.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.8.1:*:*:*:*:*:*:* Versions 0.8.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.8.2:*:*:*:*:*:*:* Versions 0.8.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.9.0:*:*:*:*:*:*:* Versions 0.9.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.9.1:*:*:*:*:*:*:* Versions 0.9.1 Vulnerable ·QEMU
Remediation
Red Hat 1 advisory
- RHSA-2008:0194 Released 2008-05-13 · Red Hat rating Importantxen security and bug fix update
- Red Hat Enterprise Linux (v. 5 server) xen-3.0.3-41.el5_1.5, xen-libs-3.0.3-41.el5_1.5, xen-libs-3.0.3-41.el5_1.5.i386 +1
- Red Hat Enterprise Linux Desktop (v. 5 client) xen-3.0.3-41.el5_1.5, xen-libs-3.0.3-41.el5_1.5, xen-libs-3.0.3-41.el5_1.5.i386
- Red Hat Enterprise Linux Desktop Multi OS (v. 5 client) xen-3.0.3-41.el5_1.5, xen-3.0.3-41.el5_1.5.i386, xen-devel-3.0.3-41.el5_1.5 +1
- Red Hat Enterprise Linux Virtualization (v. 5 server) xen-3.0.3-41.el5_1.5, xen-3.0.3-41.el5_1.5.i386, xen-3.0.3-41.el5_1.5.ia64 +3
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux (v. 5 server) | Fixed | RHSA-2008:0194 |
| Red Hat Enterprise Linux Desktop (v. 5 client) | Fixed | RHSA-2008:0194 |
| Red Hat Enterprise Linux Desktop Multi OS (v. 5 client) | Fixed | RHSA-2008:0194 |
| Red Hat Enterprise Linux Virtualization (v. 5 server) | Fixed | RHSA-2008:0194 |
Timeline
- 2026-10-02 Threatist record created from CVE-2008-0928
- 2026-10-03 Alias added: GHSA-4gr3-prqp-v6r3
References
Advisory 11
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2008-0928 · CVE Program
- CVE-2008-0928 · NVD
- FIRST EPSS
- GHSA-4gr3-prqp-v6r3 · GitHub Advisory Database · CC BY 4.0
- CVE-2008-0928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences