PowerDNS Recursor before 3.1.6 does not always use the strongest random number generator…
Priority LOW 34CWE-189Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- No fix listed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-189 and the CVSS impact.
Summary
PowerDNS Recursor before 3.1.6 does not always use the strongest random number generator for source port selection, which makes it easier for remote attack vectors to conduct DNS cache poisoning. NOTE: this is related to incomplete integration of security improvements associated with addressing CVE-2008-1637.
Why it matters now
EPSS 0.0181 78th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* | up to 3.1.5 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.1.3:*:*:*:*:*:*:* | 3.1.3 | Vulnerable | PowerDNS |
| cpe:2.3:a:powerdns:recursor:3.1.4:*:*:*:*:*:*:* | 3.1.4 | Vulnerable | PowerDNS |
- cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions up to 3.1.5 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·PowerDNS
- cpe:2.3:a:powerdns:recursor:3.1.4:*:*:*:*:*:*:* Versions 3.1.4 Vulnerable ·PowerDNS
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2008-3217
- 2026-10-03 Alias added: GHSA-2v8f-3jfm-64p5
References
Advisory 1
Other 4
More PowerDNS Recursor vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
- TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
- TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2008-3217 · CVE Program
- CVE-2008-3217 · NVD
- FIRST EPSS
- GHSA-2v8f-3jfm-64p5 · GitHub Advisory Database · CC BY 4.0
- CVE-2008-3217 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences