Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority HIGH 74
The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server 3.2.x, 3.3.x before 3.3.2, and 3.4.x before 3.4.4 allows remote attackers to ca…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.78725 · Published 2015-05-18 · No fix listed CWE-399
Priority HIGH 67
An issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending a DNS query can trigger an out-of-bounds memory read while computing the hash of the query for a packet cache lookup, poss…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.58577 · Published 2018-12-03 · No fix listed CWE-125
Priority MEDIUM 64
An issue has been found in the parsing of authoritative answers in PowerDNS Recursor before 4.0.8, leading to a NULL pointer dereference when parsing a specially crafted answer containing a CNAME of a different class tha…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.51353 · Published 2018-07-27 · No fix listed CWE-476
Priority MEDIUM 60
PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote attackers to cause a denial of service ("performance degradations") via a large or infinite number of referrals, as demonstrated by r…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.68875 · Published 2014-12-10 · No fix listed CWE-399
Priority MEDIUM 60
Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.17572 · Published 2010-01-08 · No fix listed CWE-119
Priority MEDIUM 59
An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.24495 · Published 2020-05-19 · No fix listed CWE-125
Priority MEDIUM 49
A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS query that retrieves DS records for a misconfigured domain, because QName minimization is used in QM fallback mode.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.07521 · Published 2023-01-21 · No fix listed CWE-674
Priority MEDIUM 47
The label decompression functionality in PowerDNS Recursor before 3.6.4 and 3.7.x before 3.7.3 and Authoritative (Auth) Server before 3.3.3 and 3.4.x before 3.4.5 allows remote attackers to cause a denial of service (CPU…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.11284 · Published 2015-11-02 · No fix listed CWE-399
Priority MEDIUM 45
Unspecified vulnerability in PowerDNS Recursor before 3.1.7.2 allows remote attackers to spoof DNS data via crafted zones.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.10263 · Published 2010-01-08 · No fix listed
Priority MEDIUM 44
Buffer overflow in PowerDNS Recursor 3.1.3 and earlier might allow remote attackers to execute arbitrary code via a malformed TCP DNS query that prevents Recursor from properly calculating the TCP DNS query length.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.08788 · Published 2006-11-14 · No fix listed
Priority MEDIUM 43
An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4 and 4.0.4, allowing a remote, unauthenticated attacker to cause an abnormal CPU usage load on the PowerDNS server by sending…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.07294 · Published 2018-09-11 · No fix listed CWE-20
Priority MEDIUM 42
An issue has been found in PowerDNS Recursor before 4.1.18, 4.2.x before 4.2.5, and 4.3.x before 4.3.5.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.06543 · Published 2020-10-16 · No fix listed
Priority MEDIUM 42
An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the answer section of responses received from authoritative servers with the AA flag not set were not properly validated, allowing…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00368 · Published 2019-01-29 · Fixed in 4.1.9 CWE-345
Priority MEDIUM 42
PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.06041 · Published 2018-11-29 · No fix listed CWE-400
Priority MEDIUM 41
Crafted delegations or IP fragments can poison cached delegations in Recursor.
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.00311 · Published 2026-02-09 · Fixed in 5.3.1, 5.2.6 +1 CWE-294
Priority MEDIUM 41
In PowerDNS Authoritative Server before 4.4.3, 4.5.x before 4.5.4, and 4.6.x before 4.6.1 and PowerDNS Recursor before 4.4.8, 4.5.x before 4.5.8, and 4.6.x before 4.6.1, insufficient validation of an IXFR end condition c…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.05185 · Published 2022-03-25 · No fix listed
Priority MEDIUM 40
By publishing and querying a crafted zone an attacker can cause allocation of large entries in the negative and aggressive NSEC(3) caches.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00583 · Published 2026-04-22 · Fixed in 5.4.1, 5.3.6 +1 CWE-770
Priority MEDIUM 40
An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00606 · Published 2026-04-22 · Fixed in 5.4.1, 5.3.6 +1 CWE-770
Priority MEDIUM 40
An attacker can trigger the removal of cached records by sending a NOTIFY query over TCP.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00585 · Published 2025-12-09 · Fixed in 5.3.3, 5.2.7 +1 CWE-276
Priority MEDIUM 40
PowerDNS Recursor from 4.1.0 up to and including 4.3.0 does not sufficiently defend against amplification attacks.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.04481 · Published 2020-05-19 · No fix listed CWE-400
Priority LOW 39
An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00524 · Published 2026-04-22 · Fixed in 5.0.4, 4.9.14 +5 CWE-770
Priority LOW 39
An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00514 · Published 2026-04-22 · Fixed in 5.0.4, 4.9.14 +5 CWE-770
Priority LOW 38
An issue has been found in PowerDNS Recursor versions after 4.1.3 before 4.1.9 where Lua hooks are not properly applied to queries received over TCP in some specific combination of settings, possibly bypassing security p…
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.01453 · Published 2019-01-29 · No fix listed CWE-358
Load more