Read the docs
TI-2008-04904 Aliases CVE-2008-5153GHSA-x7r4-26m9-hmgq

spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via…

Priority LOW 31CWE-59Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
—
Confidentiality · integrity · availability
Complete · Complete · Complete
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

spell-check-logic.cgi in Moodle 1.8.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.

Why it matters now

EPSS 0.0039 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed moodle/moodle (Packagist): 1.9.4, 1.8.8, 1.7.7 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)1.9.0 to before 1.9.41.9.4Patch availableGHSA-x7r4-26m9-hmgq
—moodle/moodle (Packagist)1.8.0 to before 1.8.81.8.8Patch availableGHSA-x7r4-26m9-hmgq
—moodle/moodle (Packagist)1.7.0 to before 1.7.71.7.7Patch availableGHSA-x7r4-26m9-hmgq
—moodle/moodle (Packagist)1.6.0 to before 1.6.91.6.9Patch availableGHSA-x7r4-26m9-hmgq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.4 Fixed in 1.9.4 Patch available GHSA-x7r4-26m9-hmgq
  • moodle/moodle (Packagist) Vendor— Affected 1.8.0 to before 1.8.8 Fixed in 1.8.8 Patch available GHSA-x7r4-26m9-hmgq
  • moodle/moodle (Packagist) Vendor— Affected 1.7.0 to before 1.7.7 Fixed in 1.7.7 Patch available GHSA-x7r4-26m9-hmgq
  • moodle/moodle (Packagist) Vendor— Affected 1.6.0 to before 1.6.9 Fixed in 1.6.9 Patch available GHSA-x7r4-26m9-hmgq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:*1.8.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* Versions 1.8.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-x7r4-26m9-hmgq moodle/moodle (Packagist) Fixed in 1.9.4 Advisory →
  • Fix · GHSA-x7r4-26m9-hmgq moodle/moodle (Packagist) Fixed in 1.8.8 Advisory →
  • Fix · GHSA-x7r4-26m9-hmgq moodle/moodle (Packagist) Fixed in 1.7.7 Advisory →
  • Fix · GHSA-x7r4-26m9-hmgq moodle/moodle (Packagist) Fixed in 1.6.9 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2008-5153
  2. 2026-10-03 Alias added: GHSA-x7r4-26m9-hmgq

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources