Read the docs
TI-2009-03801 Aliases CVE-2009-4009GHSA-x753-v6ch-rpgq

Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a…

Priority MEDIUM 60CWE-119Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
Complete · Complete · Complete
Fix status
No fix listed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.

Summary

Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.

Why it matters now

EPSS 0.17572 97th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 18

CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:*up to 3.1.7.2VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.0_rc1:*:*:*:*:*:*:*2.0_rc1VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.8:*:*:*:*:*:*:*2.8VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.9.15:*:*:*:*:*:*:*2.9.15VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.9.16:*:*:*:*:*:*:*2.9.16VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.9.17:*:*:*:*:*:*:*2.9.17VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:2.9.18:*:*:*:*:*:*:*2.9.18VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.0:*:*:*:*:*:*:*3.0VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.0.1:*:*:*:*:*:*:*3.0.1VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1:*:*:*:*:*:*:*3.1VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:*:*:*:*:*:*:*:* Versions up to 3.1.7.2 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.0_rc1:*:*:*:*:*:*:* Versions 2.0_rc1 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.8:*:*:*:*:*:*:* Versions 2.8 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.9.15:*:*:*:*:*:*:* Versions 2.9.15 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.9.16:*:*:*:*:*:*:* Versions 2.9.16 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.9.17:*:*:*:*:*:*:* Versions 2.9.17 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:2.9.18:*:*:*:*:*:*:* Versions 2.9.18 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1:*:*:*:*:*:*:* Versions 3.1 Vulnerable ·PowerDNS
Show 8 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:powerdns:recursor:3.1.1:*:*:*:*:*:*:*3.1.1VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.2:*:*:*:*:*:*:*3.1.2VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.3:*:*:*:*:*:*:*3.1.3VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.4:*:*:*:*:*:*:*3.1.4VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.5:*:*:*:*:*:*:*3.1.5VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.6:*:*:*:*:*:*:*3.1.6VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.7:*:*:*:*:*:*:*3.1.7VulnerablePowerDNS
cpe:2.3:a:powerdns:recursor:3.1.7.1:*:*:*:*:*:*:*3.1.7.1VulnerablePowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.4:*:*:*:*:*:*:* Versions 3.1.4 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.5:*:*:*:*:*:*:* Versions 3.1.5 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.6:*:*:*:*:*:*:* Versions 3.1.6 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.7:*:*:*:*:*:*:* Versions 3.1.7 Vulnerable ·PowerDNS
  • cpe:2.3:a:powerdns:recursor:3.1.7.1:*:*:*:*:*:*:* Versions 3.1.7.1 Vulnerable ·PowerDNS

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2009-4009
  2. 2026-10-03 Alias added: GHSA-x753-v6ch-rpgq

References

  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
  • TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
  • TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
See all 49 →

Sources