Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 1.8.0 to before 1.8.12 | 1.8.12 | Patch available | GHSA-5fgv-cvr8-xg48 |
| — | moodle/moodle (Packagist) | 1.9.0 to before 1.9.8 | 1.9.8 | Patch available | GHSA-5fgv-cvr8-xg48 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 1.8.0 to before 1.8.12 Fixed in 1.8.12 Patch available GHSA-5fgv-cvr8-xg48
- moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.8 Fixed in 1.9.8 Patch available GHSA-5fgv-cvr8-xg48
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* | 1.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* | 1.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* | 1.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* | 1.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* | 1.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* | 1.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* | 1.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* | 1.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* | 1.8.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* | 1.8.10 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* Versions 1.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* Versions 1.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* Versions 1.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* Versions 1.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* Versions 1.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* Versions 1.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* Versions 1.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* Versions 1.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* Versions 1.8.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* Versions 1.8.10 Vulnerable ·Moodle
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* | 1.8.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* | 1.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* | 1.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* | 1.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* | 1.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* | 1.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* | 1.9.7 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* Versions 1.8.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
Remediation
- Fix · GHSA-5fgv-cvr8-xg48 moodle/moodle (Packagist) Fixed in 1.8.12 Advisory →
- Fix · GHSA-5fgv-cvr8-xg48 moodle/moodle (Packagist) Fixed in 1.9.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-1614
- 2026-10-03 Alias added: GHSA-5fgv-cvr8-xg48
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2010-1614 · CVE Program
- CVE-2010-1614 · NVD
- FIRST EPSS
- GHSA-5fgv-cvr8-xg48 · GitHub Advisory Database · CC BY 4.0
- CVE-2010-1614 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences