Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which…
Priority LOW 21CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.
Why it matters now
EPSS 0.01173 67th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 1.8.12, 1.9.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 1.8.0 to before 1.8.12 | 1.8.12 | Patch available | GHSA-966m-m549-2878 |
| — | moodle/moodle (Packagist) | 1.9.0 to before 1.9.8 | 1.9.8 | Patch available | GHSA-966m-m549-2878 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 1.8.0 to before 1.8.12 Fixed in 1.8.12 Patch available GHSA-966m-m549-2878
- moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.8 Fixed in 1.9.8 Patch available GHSA-966m-m549-2878
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* | 1.8.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* | 1.8.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* | 1.8.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* | 1.8.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* | 1.8.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* | 1.8.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* | 1.8.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* | 1.8.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* | 1.8.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* | 1.8.10 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.8.1:*:*:*:*:*:*:* Versions 1.8.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.2:*:*:*:*:*:*:* Versions 1.8.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.3:*:*:*:*:*:*:* Versions 1.8.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.4:*:*:*:*:*:*:* Versions 1.8.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.5:*:*:*:*:*:*:* Versions 1.8.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.6:*:*:*:*:*:*:* Versions 1.8.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.7:*:*:*:*:*:*:* Versions 1.8.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.8:*:*:*:*:*:*:* Versions 1.8.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.9:*:*:*:*:*:*:* Versions 1.8.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.8.10:*:*:*:*:*:*:* Versions 1.8.10 Vulnerable ·Moodle
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* | 1.8.11 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* | 1.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* | 1.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* | 1.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* | 1.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* | 1.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* | 1.9.7 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.8.11:*:*:*:*:*:*:* Versions 1.8.11 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
Remediation
- Fix · GHSA-966m-m549-2878 moodle/moodle (Packagist) Fixed in 1.8.12 Advisory →
- Fix · GHSA-966m-m549-2878 moodle/moodle (Packagist) Fixed in 1.9.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2010-1616
- 2026-10-03 Alias added: GHSA-966m-m549-2878
References
Other 10
- ADV-2010-1107
- http://moodle.org/security/
- http://tracker.moodle.org/browse/MDL-16658
- https://github.com/moodle/moodle/commit/55f5b2e8b84e6390c0917195d01a3b34c33ff398
- https://github.com/moodle/moodle/commit/5d9ab024ac9c311c84716628cce9a124173a2e8b
- https://github.com/moodle/moodle/commit/5e934890c9fbe28bf89362d3eb6140208b5e3464
- https://github.com/moodle/moodle/commit/b0ccfc5ce87f09d4df814b057f5e6820d37fdad1
- https://github.com/moodle/moodle/commit/d8ada21339ecc147eccaaae97678f5368ac05f8b
- https://github.com/moodle/moodle
- http://moodle.org/security
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2010-1616 · CVE Program
- CVE-2010-1616 · NVD
- FIRST EPSS
- GHSA-966m-m549-2878 · GitHub Advisory Database · CC BY 4.0
- CVE-2010-1616 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences