Unspecified vulnerability in posting.php in phpBB before 3.0.5 has unknown impact and…
Priority LOW 35Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Unspecified vulnerability in posting.php in phpBB before 3.0.5 has unknown impact and attack vectors related to the use of a "forum id" in circumstances related to a "global announcement."
Why it matters now
EPSS 0.01227 69th percentileScored 2026-11-07
Fix Fixed phpbb/phpbb (Packagist): 3.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpbb/phpbb (Packagist) | before 3.0.5 | 3.0.5 | Patch available | GHSA-5cvh-xqhr-5g87 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpbb/phpbb (Packagist) Vendor— Affected before 3.0.5 Fixed in 3.0.5 Patch available GHSA-5cvh-xqhr-5g87
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:* | up to 3.0.4 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc1:*:*:*:*:*:* | 3.0.0 rc1 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc2:*:*:*:*:*:* | 3.0.0 rc2 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc3:*:*:*:*:*:* | 3.0.0 rc3 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc4:*:*:*:*:*:* | 3.0.0 rc4 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc5:*:*:*:*:*:* | 3.0.0 rc5 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc6:*:*:*:*:*:* | 3.0.0 rc6 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc7:*:*:*:*:*:* | 3.0.0 rc7 | Vulnerable | phpBB |
| cpe:2.3:a:phpbb:phpbb:3.0.0:rc8:*:*:*:*:*:* | 3.0.0 rc8 | Vulnerable | phpBB |
- cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:* Versions up to 3.0.4 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc1:*:*:*:*:*:* Versions 3.0.0 rc1 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc2:*:*:*:*:*:* Versions 3.0.0 rc2 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc3:*:*:*:*:*:* Versions 3.0.0 rc3 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc4:*:*:*:*:*:* Versions 3.0.0 rc4 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc5:*:*:*:*:*:* Versions 3.0.0 rc5 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc6:*:*:*:*:*:* Versions 3.0.0 rc6 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc7:*:*:*:*:*:* Versions 3.0.0 rc7 Vulnerable ·phpBB
- cpe:2.3:a:phpbb:phpbb:3.0.0:rc8:*:*:*:*:*:* Versions 3.0.0 rc8 Vulnerable ·phpBB
Remediation
- Fix · GHSA-5cvh-xqhr-5g87 phpbb/phpbb (Packagist) Fixed in 3.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-1630
- 2026-10-03 Alias added: GHSA-5cvh-xqhr-5g87
References
Advisory 2
Other 6
- [oss-security] 20100518 Re: CVE request: phpbb 3.0.7 and before 3.0.5
- http://github.com/phpbb/phpbb3/commit/4ea3402f9363c9259881bc8ea6ce7fc6cb212657
- [oss-security] 20100519 Re: CVE request: phpbb 3.0.7 and before 3.0.5
- [oss-security] 20100517 CVE request: phpbb 3.0.7 and before 3.0.5
- https://github.com/phpbb/phpbb-app/commit/1758aa38b21f5960ab1b1a241546b34a203051b6
- https://github.com/phpbb/phpbb-app
More Phpbb vulnerabilities
- TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
- TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
- TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
- TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
- TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
- TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
Sources
- CVE-2010-1630 · CVE Program
- CVE-2010-1630 · NVD
- FIRST EPSS
- GHSA-5cvh-xqhr-5g87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences