Priority HIGH 73
Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker to execute arbitrary code via the login function and the authentication mechanism
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00256 · Published 2026-04-09 · No fix listed CWE-352
Priority MEDIUM 49
prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute arbitrary PHP code via an invalid language value, which prevents the variables (1) $l_statsblock in prefs.php or (2) $l_privnotify in auth…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.07702 · Published 2005-04-21 · No fix listed CWE-665
Priority MEDIUM 46
Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors related to "urls gone through redirect() being used within login_box()."
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.01486 · Published 2008-07-18 · No fix listed
Priority MEDIUM 46
Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bugs."
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.01486 · Published 2008-04-12 · No fix listed
Priority MEDIUM 43
PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module for PHP allows remote attackers to execute arbitrary PHP code via a URL in the phpbb_root_path parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.07397 · Published 2007-03-20 · No fix listed
Priority MEDIUM 40
In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00804 · Published 2019-09-30 · Fixed in 3.1.7-PL1 CWE-352
Priority MEDIUM 40
Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with fo…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.05201 · Published 2018-11-17 · Fixed in 3.2.4 CWE-1321
Priority LOW 37
phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning.
CVSS 3.1HIGH 8.1· Network · No auth · User interaction · EPSS 0.00249 · Published 2026-05-04 · Fixed in 3.3.16, 4.0.0-a2 CWE-640
Priority LOW 37
The fulltext search component in phpBB before 3.2.6 allows Denial of Service.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02012 · Published 2019-05-02 · Fixed in 3.2.6 CWE-20
Priority LOW 36
phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web ap…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01318 · Published 2018-01-02 · Fixed in 3.2.1 CWE-918
Priority LOW 35
phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01077 · Published 2020-03-19 · Fixed in 3.2.8 CWE-94
Priority LOW 35
Unspecified vulnerability in posting.php in phpBB before 3.0.5 has unknown impact and attack vectors related to the use of a "forum id" in circumstances related to a "global announcement."
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01227 · Published 2010-05-19 · Fixed in 3.0.5
Priority LOW 35
Multiple SQL injection vulnerabilities in directory.php in the Multi-Forums (aka Multi Host Forum Pro) module 1.3.3, for phpBB and Invision Power Board (IPB or IP.Board), allow remote attackers to execute arbitrary SQL c…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01002 · Published 2007-10-29 · No fix listed CWE-89
Priority LOW 35
PHP remote file inclusion vulnerability in includes/openid/Auth/OpenID/BBStore.php in phpBB Openid 0.2.0 allows remote attackers to execute arbitrary PHP code via a URL in the openid_root_path parameter.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02798 · Published 2007-10-03 · No fix listed CWE-94
Priority LOW 35
SQL injection vulnerability in links.php in the Links MOD 1.2.2 and earlier for phpBB 2.0.22 and earlier allows remote attackers to execute arbitrary SQL commands via the start parameter in a search action.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01006 · Published 2007-09-04 · No fix listed CWE-89
Priority LOW 35
SQL injection vulnerability in privmsg.php in phpBB 2.0.3 and earlier allows remote attackers to execute arbitrary SQL commands via the mark[] parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01059 · Published 2007-11-08 · No fix listed CWE-89
Priority LOW 32
The message_options function in includes/ucp/ucp_pm_options.php in phpBB before 3.0.13 does not properly validate the form key, which allows remote attackers to conduct CSRF attacks and change the full folder setting via…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01114 · Published 2015-02-10 · No fix listed CWE-352
Priority LOW 32
phpBB 2.0.23 includes the session ID in a request to modcp.php when the moderator or administrator closes a thread, which allows remote attackers to hijack the session via a post in the thread containing a URL to a remot…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01052 · Published 2009-09-01 · No fix listed CWE-200
Priority LOW 31
Open redirect vulnerability in phpBB before 3.0.14 and 3.1.x before 3.1.4 allows remote attackers to redirect users of Google Chrome to arbitrary web sites and conduct phishing attacks via unspecified vectors.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.02048 · Published 2017-09-19 · Fixed in 3.0.14, 3.1.4 CWE-601
Priority LOW 30
phpBB version 3.2.7 allows the stealing of an Administration Control Panel session id by leveraging CSRF in the Remote Avatar feature.
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00678 · Published 2019-09-27 · Fixed in 3.2.8 CWE-352
Priority LOW 29
phpBB 3.2.8 allows a CSRF attack that can approve pending group memberships.
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00435 · Published 2020-01-14 · Fixed in 3.2.9 CWE-352
Priority LOW 29
phpbb 3.0.x-3.0.6 has an XSS vulnerability via the [flash] BB tag.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00796 · Published 2019-11-13 · No fix listed CWE-79
Priority LOW 29
PHP remote file inclusion vulnerability in includes/functions_static_topics.php in the Nivisec Static Topics module for phpBB 1.0 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the phpbb_r…
CVSS 2.0MEDIUM 5.1· Network · No auth · Interaction — · EPSS 0.03209 · Published 2006-10-06 · No fix listed CWE-94
Priority LOW 28
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00623 · Published 2023-11-02 · Fixed in 3.3.11 CWE-79
Priority LOW 28
A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.
CVSS 3.1MEDIUM 5.8· Network · No auth · No interaction · EPSS 0.00966 · Published 2020-08-17 · Fixed in 3.2.10, 3.3.1 CWE-610
Load more