qemu-kvm before 0.11.0 disables VNC authentication when the password is cleared, which…
Priority LOW 23CWE-287Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-287.
Summary
qemu-kvm before 0.11.0 disables VNC authentication when the password is cleared, which allows remote attackers to bypass authentication and establish VNC sessions.
Why it matters now
EPSS 0.0129 70th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:rc2:*:*:*:*:*:* | up to 0.11.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.0:*:*:*:*:*:*:* | 0.1.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.1:*:*:*:*:*:*:* | 0.1.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.2:*:*:*:*:*:*:* | 0.1.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.3:*:*:*:*:*:*:* | 0.1.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.4:*:*:*:*:*:*:* | 0.1.4 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.5:*:*:*:*:*:*:* | 0.1.5 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.1.6:*:*:*:*:*:*:* | 0.1.6 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.0:*:*:*:*:*:*:* | 0.10.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.1:*:*:*:*:*:*:* | 0.10.1 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:*:rc2:*:*:*:*:*:* Versions up to 0.11.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.0:*:*:*:*:*:*:* Versions 0.1.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.1:*:*:*:*:*:*:* Versions 0.1.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.2:*:*:*:*:*:*:* Versions 0.1.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.3:*:*:*:*:*:*:* Versions 0.1.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.4:*:*:*:*:*:*:* Versions 0.1.4 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.5:*:*:*:*:*:*:* Versions 0.1.5 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.1.6:*:*:*:*:*:*:* Versions 0.1.6 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.0:*:*:*:*:*:*:* Versions 0.10.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.1:*:*:*:*:*:*:* Versions 0.10.1 Vulnerable ·QEMU
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:0.10.2:*:*:*:*:*:*:* | 0.10.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.3:*:*:*:*:*:*:* | 0.10.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.4:*:*:*:*:*:*:* | 0.10.4 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.5:*:*:*:*:*:*:* | 0.10.5 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.10.6:*:*:*:*:*:*:* | 0.10.6 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.11.0:rc0:*:*:*:*:*:* | 0.11.0 rc0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:0.11.0:rc1:*:*:*:*:*:* | 0.11.0 rc1 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:0.10.2:*:*:*:*:*:*:* Versions 0.10.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.3:*:*:*:*:*:*:* Versions 0.10.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.4:*:*:*:*:*:*:* Versions 0.10.4 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.5:*:*:*:*:*:*:* Versions 0.10.5 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.10.6:*:*:*:*:*:*:* Versions 0.10.6 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.11.0:rc0:*:*:*:*:*:* Versions 0.11.0 rc0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:0.11.0:rc1:*:*:*:*:*:* Versions 0.11.0 rc1 Vulnerable ·QEMU
Remediation
Red Hat 1 advisory
- RHSA-2011:0345 Released 2011-03-10 · Red Hat rating Moderateqemu-kvm security update
- Red Hat Enterprise Linux Desktop (v. 6) qemu-img-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-tools-2:0.12.1.2-2.113.el6_0.8
- Red Hat Enterprise Linux HPC Node (v. 6) qemu-img-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-tools-2:0.12.1.2-2.113.el6_0.8
- Red Hat Enterprise Linux Server (v. 6) qemu-img-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-tools-2:0.12.1.2-2.113.el6_0.8
- Red Hat Enterprise Linux Workstation (v. 6) qemu-img-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-2:0.12.1.2-2.113.el6_0.8, qemu-kvm-tools-2:0.12.1.2-2.113.el6_0.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop (v. 6) | Fixed | RHSA-2011:0345 |
| Red Hat Enterprise Linux HPC Node (v. 6) | Fixed | RHSA-2011:0345 |
| Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2011:0345 |
| Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2011:0345 |
Timeline
- 2026-10-02 Threatist record created from CVE-2011-0011
- 2026-10-03 Alias added: GHSA-x485-7p7r-jxj7
References
Advisory 2
Other 5
- [oss-security] 20110110 Re: CVE request: qemu-kvm: Setting VNC password to empty string silently disables all authentication
- [oss-security] 20110112 Re: CVE request: qemu-kvm: Setting VNC password to empty string silently disables all authentication
- [oss-security] 20110110 CVE request: qemu-kvm: Setting VNC password to empty string silently disables all authentication
- 70992
- https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/697197
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2011-0011 · CVE Program
- CVE-2011-0011 · NVD
- FIRST EPSS
- GHSA-x485-7p7r-jxj7 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-0011 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences