Read the docs
TI-2011-03650 Aliases CVE-2011-4133GHSA-7cvw-wrj9-q5fp

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows…

Priority LOW 32CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Tampering
Confidentiality · integrity · availability
Partial · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Why it matters now

EPSS 0.01006 63rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 1.9.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)1.9.0 to before 1.9.111.9.11Patch availableGHSA-7cvw-wrj9-q5fp
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.11 Fixed in 1.9.11 Patch available GHSA-7cvw-wrj9-q5fp

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:*1.9.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:*1.9.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:*1.9.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:*1.9.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:*1.9.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:*1.9.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:*1.9.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:*1.9.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:*1.9.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:*1.9.10VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* Versions 1.9.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* Versions 1.9.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* Versions 1.9.10 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-7cvw-wrj9-q5fp moodle/moodle (Packagist) Fixed in 1.9.11 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4133
  2. 2026-10-03 Alias added: GHSA-7cvw-wrj9-q5fp

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources