Read the docs
TI-2011-03700 Aliases CVE-2011-4203GHSA-4w8m-96v9-2c86

CRLF injection vulnerability in calendar/set.php in the Calendar component in Moodle…

Priority LOW 25CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

CRLF injection vulnerability in calendar/set.php in the Calendar component in Moodle 1.9.x before 1.9.15, 2.0.x before 2.0.6, 2.1.x before 2.1.3, and 2.2 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via vectors involving the url variable.

Why it matters now

EPSS 0.01177 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed moodle/moodle (Packagist): 1.9.15, 2.0.6, 2.1.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)before 1.9.151.9.15Patch availableGHSA-4w8m-96v9-2c86
—moodle/moodle (Packagist)2.0 to before 2.0.62.0.6Patch availableGHSA-4w8m-96v9-2c86
—moodle/moodle (Packagist)2.1 to before 2.1.32.1.3Patch availableGHSA-4w8m-96v9-2c86
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected before 1.9.15 Fixed in 1.9.15 Patch available GHSA-4w8m-96v9-2c86
  • moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.6 Fixed in 2.0.6 Patch available GHSA-4w8m-96v9-2c86
  • moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-4w8m-96v9-2c86

CPE configurations NVD · 24

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:*1.9.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:*1.9.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:*1.9.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:*1.9.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:*1.9.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:*1.9.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:*1.9.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:*1.9.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:*1.9.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:*1.9.10VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* Versions 1.9.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* Versions 1.9.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* Versions 1.9.10 Vulnerable ·Moodle
Show 14 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:1.9.11:*:*:*:*:*:*:*1.9.11VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.12:*:*:*:*:*:*:*1.9.12VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.13:*:*:*:*:*:*:*1.9.13VulnerableMoodle
cpe:2.3:a:moodle:moodle:1.9.14:*:*:*:*:*:*:*1.9.14VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:*2.0.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:*2.0.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:*2.0.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:*2.0.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:*2.0.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.5:*:*:*:*:*:*:*2.0.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:1.9.11:*:*:*:*:*:*:* Versions 1.9.11 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.12:*:*:*:*:*:*:* Versions 1.9.12 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.13:*:*:*:*:*:*:* Versions 1.9.13 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:1.9.14:*:*:*:*:*:*:* Versions 1.9.14 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-4w8m-96v9-2c86 moodle/moodle (Packagist) Fixed in 1.9.15 Advisory →
  • Fix · GHSA-4w8m-96v9-2c86 moodle/moodle (Packagist) Fixed in 2.0.6 Advisory →
  • Fix · GHSA-4w8m-96v9-2c86 moodle/moodle (Packagist) Fixed in 2.1.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4203
  2. 2026-10-03 Alias added: GHSA-4w8m-96v9-2c86

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources