Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage)…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.03619 89th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-mx5g-3vxh-rgm8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-mx5g-3vxh-rgm8
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:nimish_pachapurkar:spike_phpcoverage:*:*:*:*:*:*:*:* | all versions | Vulnerable | Nimish Pachapurkar |
- cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
- cpe:2.3:a:nimish_pachapurkar:spike_phpcoverage:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·Nimish Pachapurkar
Remediation
- Fix · GHSA-mx5g-3vxh-rgm8 moodle/moodle (Packagist) Fixed in 2.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4280
- 2026-10-03 Alias added: GHSA-mx5g-3vxh-rgm8
References
Advisory 2
Other 5
- [oss-security] 20111113 Re: Fwd: DSA 2338-1 moodle security update
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=bd654f0ced8af925c27b7c94321f0c299b50b38e
- https://github.com/moodle/moodle/commit/bd654f0ced8af925c27b7c94321f0c299b50b38e
- https://github.com/moodle/moodle
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=bd654f0ced8af925c27b7c94321f0c299b50b38e
Sources
- CVE-2011-4280 · CVE Program
- CVE-2011-4280 · NVD
- FIRST EPSS
- GHSA-mx5g-3vxh-rgm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences