Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in filter/mediaplugin/filter.php in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) Flash Video (aka FLV) files and (2) YouTube videos.
Why it matters now
EPSS 0.01832 79th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 1.9.11, 2.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 1.9.0 to before 1.9.11 | 1.9.11 | Patch available | GHSA-86v9-gqh9-8268 |
| — | moodle/moodle (Packagist) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-86v9-gqh9-8268 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 1.9.0 to before 1.9.11 Fixed in 1.9.11 Patch available GHSA-86v9-gqh9-8268
- moodle/moodle (Packagist) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-86v9-gqh9-8268
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* | 1.9.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* | 1.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* | 1.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* | 1.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* | 1.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* | 1.9.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* | 1.9.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* | 1.9.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* | 1.9.10 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.9.1:*:*:*:*:*:*:* Versions 1.9.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* Versions 1.9.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* Versions 1.9.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* Versions 1.9.10 Vulnerable ·Moodle
Remediation
- Fix · GHSA-86v9-gqh9-8268 moodle/moodle (Packagist) Fixed in 1.9.11 Advisory →
- Fix · GHSA-86v9-gqh9-8268 moodle/moodle (Packagist) Fixed in 2.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4286
- 2026-10-03 Alias added: GHSA-86v9-gqh9-8268
References
Advisory 2
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4286 · CVE Program
- CVE-2011-4286 · NVD
- FIRST EPSS
- GHSA-86v9-gqh9-8268 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences