Read the docs
TI-2011-03758 Aliases CVE-2011-4291GHSA-m2pf-4pf8-45j2

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service…

Priority LOW 23CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Why it matters now

EPSS 0.01919 80th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.0.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.0.0 to before 2.0.32.0.3Patch availableGHSA-m2pf-4pf8-45j2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-m2pf-4pf8-45j2

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:*2.0.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:*2.0.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:*2.0.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-m2pf-4pf8-45j2 moodle/moodle (Packagist) Fixed in 2.0.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4291
  2. 2026-10-03 Alias added: GHSA-m2pf-4pf8-45j2

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources