Read the docs
TI-2011-03760 Aliases CVE-2011-4293GHSA-wxvp-8q8h-r6rr

The theme implementation in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 triggers…

Priority LOW 33CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Partial · Partial
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

The theme implementation in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 triggers duplicate caching of Cascading Style Sheets (CSS) and JavaScript content, which allows remote attackers to bypass intended access restrictions and write to an operating-system temporary directory via unspecified vectors.

Why it matters now

EPSS 0.02409 84th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.0.4, 2.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.0 to before 2.0.42.0.4Patch availableGHSA-wxvp-8q8h-r6rr
—moodle/moodle (Packagist)2.1 to before 2.1.12.1.1Patch availableGHSA-wxvp-8q8h-r6rr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.4 Fixed in 2.0.4 Patch available GHSA-wxvp-8q8h-r6rr
  • moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-wxvp-8q8h-r6rr

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:*2.0.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:*2.0.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:*2.0.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:*2.0.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-wxvp-8q8h-r6rr moodle/moodle (Packagist) Fixed in 2.0.4 Advisory →
  • Fix · GHSA-wxvp-8q8h-r6rr moodle/moodle (Packagist) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4293
  2. 2026-10-03 Alias added: GHSA-wxvp-8q8h-r6rr

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources