Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before…
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
Why it matters now
EPSS 0.01187 68th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.0.5, 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.0.0 to before 2.0.5 | 2.0.5 | Patch available | GHSA-h6px-pvfh-q2jv |
| — | moodle/moodle (Packagist) | 2.1.0 to before 2.1.2 | 2.1.2 | Patch available | GHSA-h6px-pvfh-q2jv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.0.0 to before 2.0.5 Fixed in 2.0.5 Patch available GHSA-h6px-pvfh-q2jv
- moodle/moodle (Packagist) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-h6px-pvfh-q2jv
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-h6px-pvfh-q2jv moodle/moodle (Packagist) Fixed in 2.0.5 Advisory →
- Fix · GHSA-h6px-pvfh-q2jv moodle/moodle (Packagist) Fixed in 2.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4299
- 2026-10-03 Alias added: GHSA-h6px-pvfh-q2jv
References
Advisory 2
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4299 · CVE Program
- CVE-2011-4299 · NVD
- FIRST EPSS
- GHSA-h6px-pvfh-q2jv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences