The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not…
Priority LOW 27CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
Why it matters now
EPSS 0.02118 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.1.2, 2.0.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.2 | 2.1.2 | Patch available | GHSA-9p54-pc88-36c4 |
| — | moodle/moodle (Packagist) | 2.0.0 to before 2.0.5 | 2.0.5 | Patch available | GHSA-9p54-pc88-36c4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-9p54-pc88-36c4
- moodle/moodle (Packagist) Vendor— Affected 2.0.0 to before 2.0.5 Fixed in 2.0.5 Patch available GHSA-9p54-pc88-36c4
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-9p54-pc88-36c4 moodle/moodle (Packagist) Fixed in 2.1.2 Advisory →
- Fix · GHSA-9p54-pc88-36c4 moodle/moodle (Packagist) Fixed in 2.0.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4300
- 2026-10-03 Alias added: GHSA-9p54-pc88-36c4
References
Advisory 2
Other 6
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=f6b07c4da54a9db24723beb147e8a19a3d487e00
- https://github.com/moodle/moodle/commit/6f7c43c7de8f62cd53a7f3b54ad5325cd109c1be
- https://github.com/moodle/moodle/commit/81c77993e3808bba68fe24d6bfbac19a41679a6f
- https://github.com/moodle/moodle/commit/f6b07c4da54a9db24723beb147e8a19a3d487e00
- https://github.com/moodle/moodle
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=f6b07c4da54a9db24723beb147e8a19a3d487e00
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4300 · CVE Program
- CVE-2011-4300 · NVD
- FIRST EPSS
- GHSA-9p54-pc88-36c4 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4300 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences