The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before…
Priority LOW 27CWE-471Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.
Why it matters now
EPSS 0.02102 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 1.9.14, 2.0.5, 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 1.9.14 | 1.9.14 | Patch available | GHSA-jcrj-gmr6-p5j8 |
| — | moodle/moodle (Packagist) | 2.0 to before 2.0.5 | 2.0.5 | Patch available | GHSA-jcrj-gmr6-p5j8 |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.2 | 2.1.2 | Patch available | GHSA-jcrj-gmr6-p5j8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 1.9.14 Fixed in 1.9.14 Patch available GHSA-jcrj-gmr6-p5j8
- moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.5 Fixed in 2.0.5 Patch available GHSA-jcrj-gmr6-p5j8
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-jcrj-gmr6-p5j8
CPE configurations NVD · 19
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* | 1.9.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* | 1.9.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* | 1.9.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* | 1.9.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* | 1.9.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* | 1.9.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* | 1.9.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* | 1.9.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* | 1.9.10 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.11:*:*:*:*:*:*:* | 1.9.11 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.9.2:*:*:*:*:*:*:* Versions 1.9.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.3:*:*:*:*:*:*:* Versions 1.9.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.4:*:*:*:*:*:*:* Versions 1.9.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.5:*:*:*:*:*:*:* Versions 1.9.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.6:*:*:*:*:*:*:* Versions 1.9.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.7:*:*:*:*:*:*:* Versions 1.9.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.8:*:*:*:*:*:*:* Versions 1.9.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.9:*:*:*:*:*:*:* Versions 1.9.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.10:*:*:*:*:*:*:* Versions 1.9.10 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.11:*:*:*:*:*:*:* Versions 1.9.11 Vulnerable ·Moodle
Show 9 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:1.9.12:*:*:*:*:*:*:* | 1.9.12 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:1.9.13:*:*:*:*:*:*:* | 1.9.13 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:1.9.12:*:*:*:*:*:*:* Versions 1.9.12 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:1.9.13:*:*:*:*:*:*:* Versions 1.9.13 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-jcrj-gmr6-p5j8 moodle/moodle (Packagist) Fixed in 1.9.14 Advisory →
- Fix · GHSA-jcrj-gmr6-p5j8 moodle/moodle (Packagist) Fixed in 2.0.5 Advisory →
- Fix · GHSA-jcrj-gmr6-p5j8 moodle/moodle (Packagist) Fixed in 2.1.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2011-4301
- 2026-10-03 Alias added: GHSA-jcrj-gmr6-p5j8
References
Advisory 2
Other 8
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
- https://bugzilla.redhat.com/show_bug.cgi?id=747444
- https://github.com/moodle/moodle/commit/1f52e72526c305989eadc702b5299edb2a50ac3c
- https://github.com/moodle/moodle/commit/2a44c5192c875c4f4b4e813d7227b19d8fda86ba
- https://github.com/moodle/moodle/commit/a6f18c98f43b6fc6b8b7c4e96af41cb4a626e1b8
- https://github.com/moodle/moodle/commit/f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
- https://github.com/moodle/moodle
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=f1f70bd4dde6cd1ea4bdb8ab28fa3d36a53b89d8
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2011-4301 · CVE Program
- CVE-2011-4301 · NVD
- FIRST EPSS
- GHSA-jcrj-gmr6-p5j8 · GitHub Advisory Database · CC BY 4.0
- CVE-2011-4301 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences