Read the docs
TI-2011-03797 Aliases CVE-2011-4332GHSA-hq9x-8m8j-5hmh

Multiple cross-site scripting (XSS) vulnerabilities in Joomla! 1.6.3 and earlier allow…

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Multiple cross-site scripting (XSS) vulnerabilities in Joomla! 1.6.3 and earlier allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Why it matters now

EPSS 0.01053 64th percentileScored 2026-11-07
Fix Fixed joomla/joomla-cms (Packagist): 1.6.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—joomla/joomla-cms (Packagist)before 1.6.41.6.4Patch availableGHSA-hq9x-8m8j-5hmh
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • joomla/joomla-cms (Packagist) Vendor— Affected before 1.6.4 Fixed in 1.6.4 Patch available GHSA-hq9x-8m8j-5hmh

CPE configurations NVD · 24

CPEVersionsRoleVendor
cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*up to 1.6.3VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:alpha:*:*:*:*:*:*1.6 alphaVulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:alpha2:*:*:*:*:*:*1.6 alpha2VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta1:*:*:*:*:*:*1.6 beta1VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta10:*:*:*:*:*:*1.6 beta10VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta11:*:*:*:*:*:*1.6 beta11VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta12:*:*:*:*:*:*1.6 beta12VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta13:*:*:*:*:*:*1.6 beta13VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta14:*:*:*:*:*:*1.6 beta14VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta15:*:*:*:*:*:*1.6 beta15VulnerableJoomla!
  • cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* Versions up to 1.6.3 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:alpha:*:*:*:*:*:* Versions 1.6 alpha Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:alpha2:*:*:*:*:*:* Versions 1.6 alpha2 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta1:*:*:*:*:*:* Versions 1.6 beta1 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta10:*:*:*:*:*:* Versions 1.6 beta10 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta11:*:*:*:*:*:* Versions 1.6 beta11 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta12:*:*:*:*:*:* Versions 1.6 beta12 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta13:*:*:*:*:*:* Versions 1.6 beta13 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta14:*:*:*:*:*:* Versions 1.6 beta14 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta15:*:*:*:*:*:* Versions 1.6 beta15 Vulnerable ·Joomla!
Show 14 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:joomla:joomla\!:1.6:beta2:*:*:*:*:*:*1.6 beta2VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta3:*:*:*:*:*:*1.6 beta3VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta4:*:*:*:*:*:*1.6 beta4VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta5:*:*:*:*:*:*1.6 beta5VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta6:*:*:*:*:*:*1.6 beta6VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta7:*:*:*:*:*:*1.6 beta7VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta8:*:*:*:*:*:*1.6 beta8VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:beta9:*:*:*:*:*:*1.6 beta9VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6:rc1:*:*:*:*:*:*1.6 rc1VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6.0:*:*:*:*:*:*:*1.6.0VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6.1:*:*:*:*:*:*:*1.6.1VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6.4:*:*:*:*:*:*:*1.6.4VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6.5:*:*:*:*:*:*:*1.6.5VulnerableJoomla!
cpe:2.3:a:joomla:joomla\!:1.6.6:*:*:*:*:*:*:*1.6.6VulnerableJoomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta2:*:*:*:*:*:* Versions 1.6 beta2 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta3:*:*:*:*:*:* Versions 1.6 beta3 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta4:*:*:*:*:*:* Versions 1.6 beta4 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta5:*:*:*:*:*:* Versions 1.6 beta5 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta6:*:*:*:*:*:* Versions 1.6 beta6 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta7:*:*:*:*:*:* Versions 1.6 beta7 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta8:*:*:*:*:*:* Versions 1.6 beta8 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:beta9:*:*:*:*:*:* Versions 1.6 beta9 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6:rc1:*:*:*:*:*:* Versions 1.6 rc1 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6.4:*:*:*:*:*:*:* Versions 1.6.4 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6.5:*:*:*:*:*:*:* Versions 1.6.5 Vulnerable ·Joomla!
  • cpe:2.3:a:joomla:joomla\!:1.6.6:*:*:*:*:*:*:* Versions 1.6.6 Vulnerable ·Joomla!

Remediation

  • Fix · GHSA-hq9x-8m8j-5hmh joomla/joomla-cms (Packagist) Fixed in 1.6.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2011-4332
  2. 2026-10-03 Alias added: GHSA-hq9x-8m8j-5hmh

References

  • TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-06410 SQL injection vulnerability in Joomla! 3.7.x before 3.7.1 allows attackers to execute… CVSS 3.0CRITICAL 9.8
  • TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
  • TI-2016-07280 The register method in the UsersModelRegistration class in controllers/user.php in the… CVSS 3.0CRITICAL 9.8
  • TI-2023-09555 [20230201] - Core - Improper access check in webservice endpoints KEVCVSS 3.1MEDIUM 5.3
  • TI-2015-07045 Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object… CVSS 2.0HIGH 7.5
See all 339 →

Sources