Read the docs
TI-2012-00734 Aliases CVE-2012-0797GHSA-72gv-qqrp-h9qg

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x…

Priority LOW 27CWE-16Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Partial · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Why it matters now

EPSS 0.01087 65th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.2.1, 2.1.4, 2.0.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.2 to before 2.2.12.2.1Patch availableGHSA-72gv-qqrp-h9qg
—moodle/moodle (Packagist)2.1 to before 2.1.42.1.4Patch availableGHSA-72gv-qqrp-h9qg
—moodle/moodle (Packagist)2.0 to before 2.0.72.0.7Patch availableGHSA-72gv-qqrp-h9qg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.1 Fixed in 2.2.1 Patch available GHSA-72gv-qqrp-h9qg
  • moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.4 Fixed in 2.1.4 Patch available GHSA-72gv-qqrp-h9qg
  • moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.7 Fixed in 2.0.7 Patch available GHSA-72gv-qqrp-h9qg

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*2.0 – 2.0.6; 2.1 – 2.1.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 2.0 – 2.0.6; 2.1 – 2.1.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-72gv-qqrp-h9qg moodle/moodle (Packagist) Fixed in 2.2.1 Advisory →
  • Fix · GHSA-72gv-qqrp-h9qg moodle/moodle (Packagist) Fixed in 2.1.4 Advisory →
  • Fix · GHSA-72gv-qqrp-h9qg moodle/moodle (Packagist) Fixed in 2.0.7 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-0797
  2. 2026-10-03 Alias added: GHSA-72gv-qqrp-h9qg

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources