Read the docs
TI-2012-01063 Aliases CVE-2012-1157GHSA-2x36-7xfm-pgm7

Incorrect default permissions in Moodle

Priority LOW 22CWE-276Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default

Why it matters now

EPSS 0.01216 68th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.2.2, 2.1.5, 2.0.8 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
MoodleMoodle2.2 to 2.2.1+; 2.1 to 2.1.4+; 2.0 to 2.0.7+—No fix listedCNA
—moodle/moodle (Packagist)2.2 to before 2.2.22.2.2Patch availableGHSA-2x36-7xfm-pgm7
—moodle/moodle (Packagist)2.1 to before 2.1.52.1.5Patch availableGHSA-2x36-7xfm-pgm7
—moodle/moodle (Packagist)2.0 to before 2.0.82.0.8Patch availableGHSA-2x36-7xfm-pgm7
—moodle/moodle (Packagist)before 1.9.171.9.17Patch availableGHSA-2x36-7xfm-pgm7
  • Moodle VendorMoodle Affected 2.2 to 2.2.1+; 2.1 to 2.1.4+; 2.0 to 2.0.7+ Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-2x36-7xfm-pgm7
  • moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.5 Fixed in 2.1.5 Patch available GHSA-2x36-7xfm-pgm7
  • moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.8 Fixed in 2.0.8 Patch available GHSA-2x36-7xfm-pgm7
  • moodle/moodle (Packagist) Vendor— Affected before 1.9.17 Fixed in 1.9.17 Patch available GHSA-2x36-7xfm-pgm7

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 2.2.2VulnerableMoodle
cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:*15VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:*16VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:*17VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 2.2.2 Vulnerable ·Moodle
  • cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:* Versions 16 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* Versions 17 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-2x36-7xfm-pgm7 moodle/moodle (Packagist) Fixed in 2.2.2 Advisory →
  • Fix · GHSA-2x36-7xfm-pgm7 moodle/moodle (Packagist) Fixed in 2.1.5 Advisory →
  • Fix · GHSA-2x36-7xfm-pgm7 moodle/moodle (Packagist) Fixed in 2.0.8 Advisory →
  • Fix · GHSA-2x36-7xfm-pgm7 moodle/moodle (Packagist) Fixed in 1.9.17 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-1157
  2. 2026-10-03 Alias added: GHSA-2x36-7xfm-pgm7

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources