Moodle before 2.2.2: Overview report allows users to see hidden courses
Priority LOW 23CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Moodle before 2.2.2: Overview report allows users to see hidden courses
Why it matters now
EPSS 0.01423 73rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.2.2, 2.1.5, 2.0.8 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Moodle | Moodle | 2.2 to 2.2.1+; 2.1 to 2.1.4+ | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.2 to before 2.2.2 | 2.2.2 | Patch available | GHSA-p9hr-f4xj-8w8r |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.5 | 2.1.5 | Patch available | GHSA-p9hr-f4xj-8w8r |
| — | moodle/moodle (Packagist) | 2.0 to before 2.0.8 | 2.0.8 | Patch available | GHSA-p9hr-f4xj-8w8r |
| — | moodle/moodle (Packagist) | before 1.9.17 | 1.9.17 | Patch available | GHSA-p9hr-f4xj-8w8r |
- Moodle VendorMoodle Affected 2.2 to 2.2.1+; 2.1 to 2.1.4+ Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-p9hr-f4xj-8w8r
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.5 Fixed in 2.1.5 Patch available GHSA-p9hr-f4xj-8w8r
- moodle/moodle (Packagist) Vendor— Affected 2.0 to before 2.0.8 Fixed in 2.0.8 Patch available GHSA-p9hr-f4xj-8w8r
- moodle/moodle (Packagist) Vendor— Affected before 1.9.17 Fixed in 1.9.17 Patch available GHSA-p9hr-f4xj-8w8r
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | before 2.2.2 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:* | 15 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:* | 16 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* | 17 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 2.2.2 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:16:*:*:*:*:*:*:* Versions 16 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:17:*:*:*:*:*:*:* Versions 17 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-p9hr-f4xj-8w8r moodle/moodle (Packagist) Fixed in 2.2.2 Advisory →
- Fix · GHSA-p9hr-f4xj-8w8r moodle/moodle (Packagist) Fixed in 2.1.5 Advisory →
- Fix · GHSA-p9hr-f4xj-8w8r moodle/moodle (Packagist) Fixed in 2.0.8 Advisory →
- Fix · GHSA-p9hr-f4xj-8w8r moodle/moodle (Packagist) Fixed in 1.9.17 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-1159
- 2026-10-03 Alias added: GHSA-p9hr-f4xj-8w8r
References
Patch 2
Advisory 7
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/081047.html
- https://security-tracker.debian.org/tracker/CVE-2012-1159
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080712.html
- https://nvd.nist.gov/vuln/detail/CVE-2012-1159
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2012-1159 · CVE Program
- CVE-2012-1159 · NVD
- FIRST EPSS
- GHSA-p9hr-f4xj-8w8r · GitHub Advisory Database · CC BY 4.0
- CVE-2012-1159 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences