Read the docs
TI-2012-02082 Aliases CVE-2012-2353GHSA-mr97-gvvg-rhgh

Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to…

Priority LOW 22CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Partial · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to obtain sensitive user information from hidden fields by leveraging the teacher role and navigating to "Enrolled users" under the Users Settings section.

Why it matters now

EPSS 0.0138 72nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.1.6, 2.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)2.1 to before 2.1.62.1.6Patch availableGHSA-mr97-gvvg-rhgh
—moodle/moodle (Packagist)2.2 to before 2.2.32.2.3Patch availableGHSA-mr97-gvvg-rhgh
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.6 Fixed in 2.1.6 Patch available GHSA-mr97-gvvg-rhgh
  • moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-mr97-gvvg-rhgh

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:*2.1.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:*2.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:*2.1.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:*2.2.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:*2.2.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-mr97-gvvg-rhgh moodle/moodle (Packagist) Fixed in 2.1.6 Advisory →
  • Fix · GHSA-mr97-gvvg-rhgh moodle/moodle (Packagist) Fixed in 2.2.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-2353
  2. 2026-10-03 Alias added: GHSA-mr97-gvvg-rhgh

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources