The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3…
Priority LOW 22CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
Why it matters now
EPSS 0.01414 72nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.1.6, 2.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.6 | 2.1.6 | Patch available | GHSA-3rqj-jchw-9cc7 |
| — | moodle/moodle (Packagist) | 2.2 to before 2.2.3 | 2.2.3 | Patch available | GHSA-3rqj-jchw-9cc7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.6 Fixed in 2.1.6 Patch available GHSA-3rqj-jchw-9cc7
- moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-3rqj-jchw-9cc7
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* | 2.1.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-3rqj-jchw-9cc7 moodle/moodle (Packagist) Fixed in 2.1.6 Advisory →
- Fix · GHSA-3rqj-jchw-9cc7 moodle/moodle (Packagist) Fixed in 2.2.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-2356
- 2026-10-03 Alias added: GHSA-3rqj-jchw-9cc7
References
Other 6
- [oss-security] 20120523 Moodle security notifications public
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-32239
- https://github.com/moodle/moodle/commit/0f83dd10a1d013e77906c7be4560126bb14c6b5c
- https://github.com/moodle/moodle/commit/29e247e44e983f230f248192ffac8e7b7abe37fd
- https://github.com/moodle/moodle/commit/51c5e6057c67687f5d872f8a228cfea275abf576
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2012-2356 · CVE Program
- CVE-2012-2356 · NVD
- FIRST EPSS
- GHSA-3rqj-jchw-9cc7 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-2356 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences