Moodle 2.3.x before 2.3.1 uses only a client-side check for whether references are…
Priority LOW 21CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
Moodle 2.3.x before 2.3.1 uses only a client-side check for whether references are permitted in a file upload, which allows remote authenticated users to bypass intended alias (aka shortcut) restrictions via a client that omits this check.
Why it matters now
EPSS 0.01128 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.3 to before 2.3.1 | 2.3.1 | Patch available | GHSA-w66h-c2vj-cm7f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.3 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-w66h-c2vj-cm7f
Remediation
- Fix · GHSA-w66h-c2vj-cm7f moodle/moodle (Packagist) Fixed in 2.3.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-3387
- 2026-10-03 Alias added: GHSA-w66h-c2vj-cm7f
References
Other 6
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-33948
- [oss-security] 20120717 Moodle security notifications public
- https://github.com/moodle/moodle/commit/3b6629c088f14c6ee8f13a009ff27441d164f334
- https://github.com/moodle/moodle/commit/61a339e59857fd36080f4a468a16cd6a539d90bb
- https://github.com/moodle/moodle
- https://web.archive.org/web/20121104220059/http://www.securityfocus.com/bid/54481
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2012-3387 · CVE Program
- CVE-2012-3387 · NVD
- FIRST EPSS
- GHSA-w66h-c2vj-cm7f · GitHub Advisory Database · CC BY 4.0
- CVE-2012-3387 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences