The Dropbox Repository File Picker in Moodle 2.1.x before 2.1.9, 2.2.x before 2.2.6, and…
Priority LOW 31CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The Dropbox Repository File Picker in Moodle 2.1.x before 2.1.9, 2.2.x before 2.2.6, and 2.3.x before 2.3.3 allows remote authenticated users to access the Dropbox of a different user by leveraging an unattended workstation after a logout.
Why it matters now
EPSS 0.01265 69th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.3.3, 2.2.6, 2.1.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.3 to before 2.3.3 | 2.3.3 | Patch available | GHSA-mpjx-8phj-5m34 |
| — | moodle/moodle (Packagist) | 2.2 to before 2.2.6 | 2.2.6 | Patch available | GHSA-mpjx-8phj-5m34 |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.9 | 2.1.9 | Patch available | GHSA-mpjx-8phj-5m34 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.3 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-mpjx-8phj-5m34
- moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.6 Fixed in 2.2.6 Patch available GHSA-mpjx-8phj-5m34
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.9 Fixed in 2.1.9 Patch available GHSA-mpjx-8phj-5m34
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* | 2.1.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* | 2.1.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* | 2.1.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* | 2.1.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* Versions 2.1.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* Versions 2.1.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* | 2.2.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* | 2.2.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* | 2.2.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* Versions 2.2.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-mpjx-8phj-5m34 moodle/moodle (Packagist) Fixed in 2.3.3 Advisory →
- Fix · GHSA-mpjx-8phj-5m34 moodle/moodle (Packagist) Fixed in 2.2.6 Advisory →
- Fix · GHSA-mpjx-8phj-5m34 moodle/moodle (Packagist) Fixed in 2.1.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-5471
- 2026-10-03 Alias added: GHSA-mpjx-8phj-5m34
References
Other 8
- https://moodle.org/mod/forum/discuss.php?d=216155
- [oss-security] 20121119 Moodle security notifications public
- https://github.com/moodle/moodle/commit/8eb614d4bb4a80ed51520bca528530914082136f
- https://github.com/moodle/moodle/commit/a3433213a1a2346c145e004ab1dc08b58279f910
- https://github.com/moodle/moodle/commit/c62a20c42b96f0195c4de075e5c58a4e7d381428
- https://github.com/moodle/moodle/commit/cd029574b699c74e55fa287f0b4db45d2dcf9fde
- https://github.com/moodle/moodle
- https://web.archive.org/web/20121202030020/http://www.securityfocus.com/bid/56505
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2012-5471 · CVE Program
- CVE-2012-5471 · NVD
- FIRST EPSS
- GHSA-mpjx-8phj-5m34 · GitHub Advisory Database · CC BY 4.0
- CVE-2012-5471 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences