The ldap_fluff gem for Ruby, as used in Red Hat CloudForms 1.1, when using Active…
Priority LOW 24CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-264.
Summary
The ldap_fluff gem for Ruby, as used in Red Hat CloudForms 1.1, when using Active Directory for authentication, allows remote attackers to bypass authentication via unspecified vectors.
Why it matters now
EPSS 0.01752 78th percentileScored 2026-11-07
Fix Partial ldap_fluff (RubyGems): 0.4.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ldap_fluff (RubyGems) | before 0.4.0 | 0.4.0 | Patch available | GHSA-9whh-582r-589h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ldap_fluff (RubyGems) Vendor— Affected before 0.4.0 Fixed in 0.4.0 Patch available GHSA-9whh-582r-589h
Remediation
- Fix · GHSA-9whh-582r-589h ldap_fluff (RubyGems) Fixed in 0.4.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Subscription Asset Manager | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2012-5604
- 2026-10-03 Alias added: GHSA-9whh-582r-589h
References
More Red Hat Cloudforms vulnerabilities
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2017-08592 The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4… CVSS 3.0HIGH 8.8
- TI-2019-08480 jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles… CVSS 3.1MEDIUM 6.1
- TI-2018-05593 transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before… CVSS 3.1CRITICAL 9.8
- TI-2018-02756 Path traversal in HackerOne Sprockets CVSS 3.0HIGH 7.5
- TI-2018-00978 Improper input validation in postgresql CVSS 3.1HIGH 8.8
Sources
- CVE-2012-5604 · CVE Program
- CVE-2012-5604 · NVD
- FIRST EPSS
- GHSA-9whh-582r-589h · GitHub Advisory Database · CC BY 4.0
- CVE-2012-5604 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences