Priority CRITICAL 90KEV
There is a File Content Disclosure vulnerability in Action View <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 and v3 where specially crafted accept headers can cause contents of arbitrary files on the target system's filesyste…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.98507 · Published 2019-03-27 · Fixed in 5.2.2.1, 4.2.11.1 +2 CWE-22
Priority HIGH 80
The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nest…
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.87549 · Published 2017-08-23 · Partial fix · 3.0.1, 3.1.4 +2 CWE-276
Priority HIGH 69
jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.8682 · Published 2019-04-19 · Partial fix · 3.4.0, 4.3.4 +3 CWE-1321
Priority MEDIUM 64
transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before 1.18.5, 2.0.x before 2.0.8, 2.1.x before 2.1.5, 2.2.x before 2.2.3, 2.3.x before 2.3.2, and 2.4.x before 2.4.1 does not properly chec…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.27105 · Published 2018-03-13 · Partial fix · 2.0.8, 2.1.5 +5 CWE-287
Priority MEDIUM 55
There is an information leak vulnerability in Sprockets.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.26346 · Published 2018-06-26 · Partial fix · 3.7.2, 4.0.0.beta8 +1 CWE-22
Priority MEDIUM 53
A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.13098 · Published 2018-03-02 · Partial fix CWE-20
Priority MEDIUM 49
rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04339 · Published 2018-06-26 · Partial fix · 1.2.2 CWE-434
Priority MEDIUM 47
A code injection flaw was found in the way capacity and utilization imported control files are processed.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.05931 · Published 2018-10-31 · Fixed CWE-94
Priority MEDIUM 44
There is a possible denial of service vulnerability in Action View (Rails) <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 where specially crafted accept headers can cause action view to consume 100% cpu and make the server unre…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0844 · Published 2019-03-27 · Fixed in 4.2.11.1, 5.2.2.1 +3 CWE-400
Priority MEDIUM 43
Ansible Tower through version 3.2.3 has a vulnerability that allows users only with access to define variables for a job template to execute arbitrary code on the Tower server.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0247 · Published 2018-05-02 · Fixed CWE-20
Priority MEDIUM 43
The web UI in Red Hat CloudForms 4.1 allows remote authenticated users to execute arbitrary code via vectors involving "Lack of field filters."
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02626 · Published 2016-08-26 · Fixed CWE-284
Priority MEDIUM 42
It was found that the CloudForms before 5.6.2.2, and 5.7.0.7 did not properly apply permissions controls to VM IDs passed by users.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02197 · Published 2018-09-10 · Fixed CWE-285
Priority MEDIUM 42
ManageIQ in CloudForms before 4.1 allows remote authenticated users to execute arbitrary code.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02305 · Published 2017-06-08 · Fixed CWE-264
Priority MEDIUM 41
Red Hat CloudForms before 5.11.7.0 was vulnerable to the User Impersonation authorization flaw which allows malicious attacker to create existent and non-existent role-based access control user, with groups and roles.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.01087 · Published 2020-08-11 · Fixed
Priority MEDIUM 41
In CloudForms Management Engine (cfme) before 5.7.3 and 5.8.x before 5.8.1, it was found that privilege check is missing when invoking arbitrary methods via filtering on VMs that MiqExpression will execute that is trigge…
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01681 · Published 2018-07-26 · Fixed CWE-862
Priority MEDIUM 40
A flaw was found in Ansible Tower's interface before 3.1.5 and 3.2.0 with SCM repositories.
CVSS 3.0HIGH 8.4· Network · High privileges · User interaction · EPSS 0.01707 · Published 2018-07-27 · Partial fix CWE-20
Priority LOW 39
CFME: CSRF protection vulnerability via permissive check of the referrer header
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00684 · Published 2019-12-13 · Fixed CWE-352
Priority LOW 38
Red Hat CloudForms 4.7 and 5 is affected by a role-based privilege escalation flaw.
CVSS 3.1HIGH 8.3· Network · Low privileges · No interaction · EPSS 0.01 · Published 2020-08-11 · Fixed
Priority LOW 38
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they shoul…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02865 · Published 2018-11-30 · Partial fix · 4.2.11, 5.0.7.1 +2 CWE-284
Priority LOW 37
A flaw was found in Cloudforms.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00769 · Published 2021-06-07 · Fixed CWE-285
Priority LOW 36
The x_button method in the ServiceController (vmdb/app/controllers/service_controller.rb) in Red Hat CloudForms 3.0 Management Engine 5.2 allows remote attackers to execute arbitrary methods via unspecified vectors.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01587 · Published 2014-03-18 · Fixed CWE-94
Priority LOW 35
CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms.
CVSS 3.0HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00474 · Published 2018-07-24 · Fixed CWE-284
Priority LOW 35
Ansible Tower before version 3.2.4 has a flaw in the management of system and organization administrators that allows for privilege escalation.
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01942 · Published 2018-05-02 · Fixed in 3.2.4 CWE-266
Priority LOW 35
It was found that CloudForms does not verify that the server hostname matches the domain name in the certificate when using a custom CA and communicating with Red Hat Virtualization (RHEV) and OpenShift.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01123 · Published 2018-07-27 · Fixed CWE-295
Priority LOW 34
A flaw was found in the CloudForms account configuration when using VMware.
CVSS 3.0HIGH 7.4· Network · Low privileges · No interaction · EPSS 0.00877 · Published 2018-02-28 · Fixed CWE-284
Load more