The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before…
Priority LOW 21CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 does not properly validate pathnames, which allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.
Why it matters now
EPSS 0.01118 66th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.4.1, 2.3.4, 2.2.7 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 2.4 to before 2.4.1 | 2.4.1 | Patch available | GHSA-cr78-rphw-w73p |
| — | moodle/moodle (Packagist) | 2.3 to before 2.3.4 | 2.3.4 | Patch available | GHSA-cr78-rphw-w73p |
| — | moodle/moodle (Packagist) | 2.2 to before 2.2.7 | 2.2.7 | Patch available | GHSA-cr78-rphw-w73p |
| — | moodle/moodle (Packagist) | 2.1 to before 2.1.10 | 2.1.10 | Patch available | GHSA-cr78-rphw-w73p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 2.4 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-cr78-rphw-w73p
- moodle/moodle (Packagist) Vendor— Affected 2.3 to before 2.3.4 Fixed in 2.3.4 Patch available GHSA-cr78-rphw-w73p
- moodle/moodle (Packagist) Vendor— Affected 2.2 to before 2.2.7 Fixed in 2.2.7 Patch available GHSA-cr78-rphw-w73p
- moodle/moodle (Packagist) Vendor— Affected 2.1 to before 2.1.10 Fixed in 2.1.10 Patch available GHSA-cr78-rphw-w73p
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* | 2.1.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* | 2.1.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* | 2.1.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* | 2.1.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* | 2.1.8 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:* | 2.1.9 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* Versions 2.1.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* Versions 2.1.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:* Versions 2.1.9 Vulnerable ·Moodle
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* | 2.2.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* | 2.2.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* | 2.2.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:* | 2.2.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* Versions 2.2.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:* Versions 2.2.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Moodle
Remediation
- Fix · GHSA-cr78-rphw-w73p moodle/moodle (Packagist) Fixed in 2.4.1 Advisory →
- Fix · GHSA-cr78-rphw-w73p moodle/moodle (Packagist) Fixed in 2.3.4 Advisory →
- Fix · GHSA-cr78-rphw-w73p moodle/moodle (Packagist) Fixed in 2.2.7 Advisory →
- Fix · GHSA-cr78-rphw-w73p moodle/moodle (Packagist) Fixed in 2.1.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2012-6099
- 2026-10-03 Alias added: GHSA-cr78-rphw-w73p
References
Advisory 2
Other 5
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-36977
- [oss-security] 20130121 Moodle security notifications public
- https://github.com/moodle/moodle/commit/0ab681d3e7bed2a37430387f9da8504c0b077d10
- https://github.com/moodle/moodle/commit/7b66137f7bcc84fb5eb07f58fb658b21bf37cc44
- https://github.com/moodle/moodle
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2012-6099 · CVE Program
- CVE-2012-6099 · NVD
- FIRST EPSS
- GHSA-cr78-rphw-w73p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences