Improper privilege management in qemu
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
A flaw was found in the way qemu v1.3.0 and later (virtio-rng) validates addresses when guest accesses the config space of a virtio device. If the virtio device has zero/small sized config space, such as virtio-rng, a privileged guest user could use this flaw to access the matching host's qemu address space and thus increase their privileges on the host.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QEMU | qemu (virtio-rng) | v1.3.0 and later | — | No fix listed | CNA |
- qemu (virtio-rng) VendorQEMU Affected v1.3.0 and later Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | 1.3.0 – 1.4.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.0:rc1:*:*:*:*:*:* | 1.5.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:novell:open_desktop_server:11.0:sp3:*:*:*:linux_kernel:*:* | 11.0 sp3 | Vulnerable | Novell |
| cpe:2.3:a:novell:open_enterprise_server:11.0:sp3:*:*:*:linux_kernel:*:* | 11.0 sp3 | Vulnerable | Novell |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions 1.3.0 – 1.4.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.0:rc1:*:*:*:*:*:* Versions 1.5.0 rc1 Vulnerable ·QEMU
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:novell:open_desktop_server:11.0:sp3:*:*:*:linux_kernel:*:* Versions 11.0 sp3 Vulnerable ·Novell
- cpe:2.3:a:novell:open_enterprise_server:11.0:sp3:*:*:*:linux_kernel:*:* Versions 11.0 sp3 Vulnerable ·Novell
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2013-2016
- 2026-10-03 Alias added: GHSA-hch7-9gh2-qf6g
References
Exploit 3
Patch 2
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2013-2016 · CVE Program
- CVE-2013-2016 · NVD
- FIRST EPSS
- GHSA-hch7-9gh2-qf6g · GitHub Advisory Database · CC BY 4.0
- CVE-2013-2016 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences