Read the docs
TI-2013-01853 Aliases CVE-2013-2082GHSA-wp3g-pr4h-q6vv

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4…

Priority LOW 27CWE-264Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Partial · None · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.

Summary

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.

Why it matters now

EPSS 0.02308 83rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 2.2.10, 2.3.7, 2.4.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—moodle/moodle (Packagist)before 2.2.102.2.10Patch availableGHSA-wp3g-pr4h-q6vv
—moodle/moodle (Packagist)2.3.0 to before 2.3.72.3.7Patch availableGHSA-wp3g-pr4h-q6vv
—moodle/moodle (Packagist)2.4.0 to before 2.4.42.4.4Patch availableGHSA-wp3g-pr4h-q6vv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected before 2.2.10 Fixed in 2.2.10 Patch available GHSA-wp3g-pr4h-q6vv
  • moodle/moodle (Packagist) Vendor— Affected 2.3.0 to before 2.3.7 Fixed in 2.3.7 Patch available GHSA-wp3g-pr4h-q6vv
  • moodle/moodle (Packagist) Vendor— Affected 2.4.0 to before 2.4.4 Fixed in 2.4.4 Patch available GHSA-wp3g-pr4h-q6vv

CPE configurations NVD · 32

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*2.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:*2.1.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:*2.1.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:*2.1.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:*2.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:*2.1.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:*2.1.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:*2.1.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:*2.1.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:*2.1.9VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.4:*:*:*:*:*:*:* Versions 2.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.6:*:*:*:*:*:*:* Versions 2.1.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.7:*:*:*:*:*:*:* Versions 2.1.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.8:*:*:*:*:*:*:* Versions 2.1.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.1.9:*:*:*:*:*:*:* Versions 2.1.9 Vulnerable ·Moodle
Show 22 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:2.1.10:*:*:*:*:*:*:*2.1.10VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*2.2.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:*2.2.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:*2.2.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:*2.2.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:*2.2.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:*2.2.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:*2.2.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.7:*:*:*:*:*:*:*2.2.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.8:*:*:*:*:*:*:*2.2.8VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.2.9:*:*:*:*:*:*:*2.2.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:*2.3.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:*2.3.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:*2.3.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:*2.3.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.4:*:*:*:*:*:*:*2.3.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.5:*:*:*:*:*:*:*2.3.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.3.6:*:*:*:*:*:*:*2.3.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:*2.4.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.4.1:*:*:*:*:*:*:*2.4.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.4.2:*:*:*:*:*:*:*2.4.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:2.4.3:*:*:*:*:*:*:*2.4.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:2.1.10:*:*:*:*:*:*:* Versions 2.1.10 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.5:*:*:*:*:*:*:* Versions 2.2.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.6:*:*:*:*:*:*:* Versions 2.2.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.7:*:*:*:*:*:*:* Versions 2.2.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.8:*:*:*:*:*:*:* Versions 2.2.8 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.2.9:*:*:*:*:*:*:* Versions 2.2.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.4:*:*:*:*:*:*:* Versions 2.3.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.5:*:*:*:*:*:*:* Versions 2.3.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.3.6:*:*:*:*:*:*:* Versions 2.3.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:2.4.3:*:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-wp3g-pr4h-q6vv moodle/moodle (Packagist) Fixed in 2.2.10 Advisory →
  • Fix · GHSA-wp3g-pr4h-q6vv moodle/moodle (Packagist) Fixed in 2.3.7 Advisory →
  • Fix · GHSA-wp3g-pr4h-q6vv moodle/moodle (Packagist) Fixed in 2.4.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-2082
  2. 2026-10-03 Alias added: GHSA-wp3g-pr4h-q6vv

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources