Buffer overflow in virtio_net_load function in net/virtio-net.c in QEMU 1.3.0 through…
Priority MEDIUM 41CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Buffer overflow in virtio_net_load function in net/virtio-net.c in QEMU 1.3.0 through 1.7.x before 1.7.2 might allow remote attackers to execute arbitrary code via a large MAC table.
Why it matters now
EPSS 0.05261 92nd percentileScored 2026-11-07
Fix Fixed Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 21
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.3.0:rc0:*:*:*:*:*:* | 1.3.0 rc0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.3.0:rc1:*:*:*:*:*:* | 1.3.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.3.0:rc2:*:*:*:*:*:* | 1.3.0 rc2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.4.1:*:*:*:*:*:*:* | 1.4.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.4.2:*:*:*:*:*:*:* | 1.4.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.0:rc1:*:*:*:*:*:* | 1.5.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.0:rc2:*:*:*:*:*:* | 1.5.0 rc2 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.3.0:rc0:*:*:*:*:*:* Versions 1.3.0 rc0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.3.0:rc1:*:*:*:*:*:* Versions 1.3.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.3.0:rc2:*:*:*:*:*:* Versions 1.3.0 rc2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.4.1:*:*:*:*:*:*:* Versions 1.4.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.4.2:*:*:*:*:*:*:* Versions 1.4.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.0:rc1:*:*:*:*:*:* Versions 1.5.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.0:rc2:*:*:*:*:*:* Versions 1.5.0 rc2 Vulnerable ·QEMU
Show 11 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:1.5.0:rc3:*:*:*:*:*:* | 1.5.0 rc3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.5.3:*:*:*:*:*:*:* | 1.5.3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.0:*:*:*:*:*:*:* | 1.6.0 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.0:rc1:*:*:*:*:*:* | 1.6.0 rc1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.0:rc2:*:*:*:*:*:* | 1.6.0 rc2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.0:rc3:*:*:*:*:*:* | 1.6.0 rc3 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.6.2:*:*:*:*:*:*:* | 1.6.2 | Vulnerable | QEMU |
| cpe:2.3:a:qemu:qemu:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | QEMU |
- cpe:2.3:a:qemu:qemu:1.5.0:rc3:*:*:*:*:*:* Versions 1.5.0 rc3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.5.3:*:*:*:*:*:*:* Versions 1.5.3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.0:rc1:*:*:*:*:*:* Versions 1.6.0 rc1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.0:rc2:*:*:*:*:*:* Versions 1.6.0 rc2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.0:rc3:*:*:*:*:*:* Versions 1.6.0 rc3 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.6.2:*:*:*:*:*:*:* Versions 1.6.2 Vulnerable ·QEMU
- cpe:2.3:a:qemu:qemu:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·QEMU
Remediation
Red Hat 2 advisories
- RHSA-2014:1268 Released 2014-09-22 · Red Hat rating Moderateqemu-kvm-rhev security update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 libcacard-devel-rhev-10:1.5.3-60.el7_0.7, libcacard-rhev-10:1.5.3-60.el7_0.7, libcacard-tools-rhev-10:1.5.3-60.el7_0.7 +4
- RHSA-2014:0927 Released 2014-07-23 · Red Hat rating Moderateqemu-kvm security and bug fix update
- Red Hat Enterprise Linux Client (v. 7) libcacard-10:1.5.3-60.el7_0.5, qemu-guest-agent-10:1.5.3-60.el7_0.5, qemu-img-10:1.5.3-60.el7_0.5 +3
- Red Hat Enterprise Linux Client Optional (v. 7) libcacard-devel-10:1.5.3-60.el7_0.5, libcacard-tools-10:1.5.3-60.el7_0.5
- Red Hat Enterprise Linux ComputeNode (v. 7) qemu-guest-agent-10:1.5.3-60.el7_0.5, qemu-kvm-10:1.5.3-60.el7_0.5
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) libcacard-10:1.5.3-60.el7_0.5, libcacard-devel-10:1.5.3-60.el7_0.5, libcacard-tools-10:1.5.3-60.el7_0.5 +4
- Red Hat Enterprise Linux Server (v. 7) libcacard-10:1.5.3-60.el7_0.5, qemu-guest-agent-10:1.5.3-60.el7_0.5, qemu-img-10:1.5.3-60.el7_0.5 +3
- Red Hat Enterprise Linux Server Optional (v. 7) libcacard-devel-10:1.5.3-60.el7_0.5, libcacard-tools-10:1.5.3-60.el7_0.5
- Red Hat Enterprise Linux Workstation (v. 7) libcacard-10:1.5.3-60.el7_0.5, qemu-guest-agent-10:1.5.3-60.el7_0.5, qemu-img-10:1.5.3-60.el7_0.5 +3
- Red Hat Enterprise Linux Workstation Optional (v. 7) libcacard-devel-10:1.5.3-60.el7_0.5, libcacard-tools-10:1.5.3-60.el7_0.5
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | Fixed | RHSA-2014:1268 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2014:0927 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2014:0927 |
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4149
- 2026-10-03 Alias added: GHSA-jrjq-vp8r-94w4
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2013-4149 · CVE Program
- CVE-2013-4149 · NVD
- FIRST EPSS
- GHSA-jrjq-vp8r-94w4 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4149 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences