Cross-site scripting in ember-source
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In general, Ember.js escapes or strips any user-supplied content before inserting it in strings that will be sent to innerHTML. However, the `tagName` property of an `Ember.View` was inserted into such a string without being sanitized. This means that if an application assigns a view's `tagName` to user-supplied data, a specially-crafted payload could execute arbitrary JavaScript in the context of the current domain ("XSS"). This vulnerability only affects applications that assign or bind user-provided content to `tagName`.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ember-source | ember-source < 1.0.0.rc1.1 | — | No fix listed | CNA |
| — | ember-source (RubyGems) | before 1.0.0.rc1.1 | 1.0.0.rc1.1 | Patch available | GHSA-5m48-c37x-f792 |
| — | ember-source (RubyGems) | 1.0.0.rc2.0 to before 1.0.0.rc2.1 | 1.0.0.rc2.1 | Patch available | GHSA-5m48-c37x-f792 |
| — | ember-source (RubyGems) | 1.0.0.rc3.0 to before 1.0.0.rc3.1 | 1.0.0.rc3.1 | Patch available | GHSA-5m48-c37x-f792 |
| — | ember-source (RubyGems) | 1.0.0.rc4.0 to before 1.0.0.rc4.1 | 1.0.0.rc4.1 | Patch available | GHSA-5m48-c37x-f792 |
| — | ember-source (RubyGems) | 1.0.0.rc5.0 to before 1.0.0.rc5.1 | 1.0.0.rc5.1 | Patch available | GHSA-5m48-c37x-f792 |
| — | ember-source (RubyGems) | 1.0.0.rc6.0 to before 1.0.0.rc6.1 | 1.0.0.rc6.1 | Patch available | GHSA-5m48-c37x-f792 |
- ember-source Vendor— Affected ember-source < 1.0.0.rc1.1 Fixed in — No fix listed CNA
- ember-source (RubyGems) Vendor— Affected before 1.0.0.rc1.1 Fixed in 1.0.0.rc1.1 Patch available GHSA-5m48-c37x-f792
- ember-source (RubyGems) Vendor— Affected 1.0.0.rc2.0 to before 1.0.0.rc2.1 Fixed in 1.0.0.rc2.1 Patch available GHSA-5m48-c37x-f792
- ember-source (RubyGems) Vendor— Affected 1.0.0.rc3.0 to before 1.0.0.rc3.1 Fixed in 1.0.0.rc3.1 Patch available GHSA-5m48-c37x-f792
- ember-source (RubyGems) Vendor— Affected 1.0.0.rc4.0 to before 1.0.0.rc4.1 Fixed in 1.0.0.rc4.1 Patch available GHSA-5m48-c37x-f792
- ember-source (RubyGems) Vendor— Affected 1.0.0.rc5.0 to before 1.0.0.rc5.1 Fixed in 1.0.0.rc5.1 Patch available GHSA-5m48-c37x-f792
- ember-source (RubyGems) Vendor— Affected 1.0.0.rc6.0 to before 1.0.0.rc6.1 Fixed in 1.0.0.rc6.1 Patch available GHSA-5m48-c37x-f792
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:emberjs:ember.js:*:*:*:*:*:*:*:* | before 1.0.0 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc1:*:*:*:*:*:* | 1.0.0 rc1 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc2:*:*:*:*:*:* | 1.0.0 rc2 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc3:*:*:*:*:*:* | 1.0.0 rc3 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc4:*:*:*:*:*:* | 1.0.0 rc4 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc5:*:*:*:*:*:* | 1.0.0 rc5 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.0.0:rc6:*:*:*:*:*:* | 1.0.0 rc6 | Vulnerable | Emberjs |
- cpe:2.3:a:emberjs:ember.js:*:*:*:*:*:*:*:* Versions before 1.0.0 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc2:*:*:*:*:*:* Versions 1.0.0 rc2 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc3:*:*:*:*:*:* Versions 1.0.0 rc3 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc4:*:*:*:*:*:* Versions 1.0.0 rc4 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc5:*:*:*:*:*:* Versions 1.0.0 rc5 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.0.0:rc6:*:*:*:*:*:* Versions 1.0.0 rc6 Vulnerable ·Emberjs
Remediation
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc1.1 Advisory →
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc2.1 Advisory →
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc3.1 Advisory →
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc4.1 Advisory →
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc5.1 Advisory →
- Fix · GHSA-5m48-c37x-f792 ember-source (RubyGems) Fixed in 1.0.0.rc6.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4170
- 2026-10-03 Alias added: GHSA-5m48-c37x-f792
References
Advisory 2
More Emberjs Ember.js vulnerabilities
- TI-2015-06292 Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before… CVSS 3.0MEDIUM 6.1
- TI-2015-01676 Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2. CVSS 3.0MEDIUM 6.1
- TI-2014-00014 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4
- TI-2014-00013 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4
- TI-2014-00044 Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before… CVSS 2.0LOW 2.6
Sources
- CVE-2013-4170 · CVE Program
- CVE-2013-4170 · NVD
- FIRST EPSS
- GHSA-5m48-c37x-f792 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4170 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences