Read the docs
TI-2014-00044 Aliases CVE-2014-0046GHSA-4q53-fqhc-cr46

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before…

Priority LOW 16CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.

Why it matters now

EPSS 0.01503 74th percentileScored 2026-11-07
Fix Fixed ember-source (RubyGems): 1.2.2, 1.3.2, 1.4.0.beta.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ember-source (RubyGems)1.2.0 to before 1.2.21.2.2Patch availableGHSA-4q53-fqhc-cr46
—ember-source (RubyGems)1.3.0 to before 1.3.21.3.2Patch availableGHSA-4q53-fqhc-cr46
—ember-source (RubyGems)1.4.0.beta.1 to before 1.4.0.beta.61.4.0.beta.6Patch availableGHSA-4q53-fqhc-cr46
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ember-source (RubyGems) Vendor— Affected 1.2.0 to before 1.2.2 Fixed in 1.2.2 Patch available GHSA-4q53-fqhc-cr46
  • ember-source (RubyGems) Vendor— Affected 1.3.0 to before 1.3.2 Fixed in 1.3.2 Patch available GHSA-4q53-fqhc-cr46
  • ember-source (RubyGems) Vendor— Affected 1.4.0.beta.1 to before 1.4.0.beta.6 Fixed in 1.4.0.beta.6 Patch available GHSA-4q53-fqhc-cr46

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:emberjs:ember.js:1.2.0:*:*:*:*:*:*:*1.2.0VulnerableEmberjs
cpe:2.3:a:emberjs:ember.js:1.2.1:*:*:*:*:*:*:*1.2.1VulnerableEmberjs
cpe:2.3:a:emberjs:ember.js:1.3.0:*:*:*:*:*:*:*1.3.0VulnerableEmberjs
cpe:2.3:a:emberjs:ember.js:1.3.1:*:*:*:*:*:*:*1.3.1VulnerableEmberjs
cpe:2.3:a:emberjs:ember.js:1.4.0:beta:*:*:*:*:*:*1.4.0 betaVulnerableEmberjs
  • cpe:2.3:a:emberjs:ember.js:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Emberjs
  • cpe:2.3:a:emberjs:ember.js:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·Emberjs
  • cpe:2.3:a:emberjs:ember.js:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Emberjs
  • cpe:2.3:a:emberjs:ember.js:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Emberjs
  • cpe:2.3:a:emberjs:ember.js:1.4.0:beta:*:*:*:*:*:* Versions 1.4.0 beta Vulnerable ·Emberjs

Remediation

  • Fix · GHSA-4q53-fqhc-cr46 ember-source (RubyGems) Fixed in 1.2.2 Advisory →
  • Fix · GHSA-4q53-fqhc-cr46 ember-source (RubyGems) Fixed in 1.3.2 Advisory →
  • Fix · GHSA-4q53-fqhc-cr46 ember-source (RubyGems) Fixed in 1.4.0.beta.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-0046
  2. 2026-10-03 Alias added: GHSA-4q53-fqhc-cr46

References

  • TI-2015-06292 Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before… CVSS 3.0MEDIUM 6.1
  • TI-2015-01676 Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2. CVSS 3.0MEDIUM 6.1
  • TI-2013-03643 Cross-site scripting in ember-source CVSS 3.1MEDIUM 6.1
  • TI-2014-00014 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4
  • TI-2014-00013 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4

Sources