Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Why it matters now
EPSS 0.0112 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ember-source (RubyGems): 1.10.1, 1.11.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ember-source (RubyGems) | 1.10.0 to before 1.10.1 | 1.10.1 | Patch available | GHSA-mp78-r56v-45qc |
| — | ember-source (RubyGems) | 1.11.0 to before 1.11.2 | 1.11.2 | Patch available | GHSA-mp78-r56v-45qc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ember-source (RubyGems) Vendor— Affected 1.10.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-mp78-r56v-45qc
- ember-source (RubyGems) Vendor— Affected 1.11.0 to before 1.11.2 Fixed in 1.11.2 Patch available GHSA-mp78-r56v-45qc
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:emberjs:ember.js:1.10.0:*:*:*:*:*:*:* | 1.10.0 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.10.0:beta1:*:*:*:*:*:* | 1.10.0 beta1 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.10.0:beta2:*:*:*:*:*:* | 1.10.0 beta2 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.10.0:beta3:*:*:*:*:*:* | 1.10.0 beta3 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.10.0:beta4:*:*:*:*:*:* | 1.10.0 beta4 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.11.0:*:*:*:*:*:*:* | 1.11.0 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.11.0:beta1:*:*:*:*:*:* | 1.11.0 beta1 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.11.0:beta2:*:*:*:*:*:* | 1.11.0 beta2 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.11.0:beta3:*:*:*:*:*:* | 1.11.0 beta3 | Vulnerable | Emberjs |
| cpe:2.3:a:emberjs:ember.js:1.11.0:beta4:*:*:*:*:*:* | 1.11.0 beta4 | Vulnerable | Emberjs |
- cpe:2.3:a:emberjs:ember.js:1.10.0:*:*:*:*:*:*:* Versions 1.10.0 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.10.0:beta1:*:*:*:*:*:* Versions 1.10.0 beta1 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.10.0:beta2:*:*:*:*:*:* Versions 1.10.0 beta2 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.10.0:beta3:*:*:*:*:*:* Versions 1.10.0 beta3 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.10.0:beta4:*:*:*:*:*:* Versions 1.10.0 beta4 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.11.0:*:*:*:*:*:*:* Versions 1.11.0 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.11.0:beta1:*:*:*:*:*:* Versions 1.11.0 beta1 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.11.0:beta2:*:*:*:*:*:* Versions 1.11.0 beta2 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.11.0:beta3:*:*:*:*:*:* Versions 1.11.0 beta3 Vulnerable ·Emberjs
- cpe:2.3:a:emberjs:ember.js:1.11.0:beta4:*:*:*:*:*:* Versions 1.11.0 beta4 Vulnerable ·Emberjs
Remediation
- Fix · GHSA-mp78-r56v-45qc ember-source (RubyGems) Fixed in 1.10.1 Advisory →
- Fix · GHSA-mp78-r56v-45qc ember-source (RubyGems) Fixed in 1.11.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1866
- 2026-10-03 Alias added: GHSA-mp78-r56v-45qc
References
Advisory 2
More Emberjs Ember.js vulnerabilities
- TI-2015-06292 Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before… CVSS 3.0MEDIUM 6.1
- TI-2013-03643 Cross-site scripting in ember-source CVSS 3.1MEDIUM 6.1
- TI-2014-00014 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4
- TI-2014-00013 Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1… CVSS 3.0MEDIUM 5.4
- TI-2014-00044 Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before… CVSS 2.0LOW 2.6
Sources
- CVE-2015-1866 · CVE Program
- CVE-2015-1866 · NVD
- FIRST EPSS
- GHSA-mp78-r56v-45qc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences