BestWebSoft Contact Form Plugin contact_form.php cntctfrm_check_form cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, has been found in BestWebSoft Contact Form Plugin 3.51 on WordPress. Affected by this issue is the function cntctfrm_display_form/cntctfrm_check_form of the file contact_form.php. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 3.52 is able to address this issue. The patch is identified as 642ef1dc1751ab6642ce981fe126325bb574f898. It is recommended to upgrade the affected component. VDB-225002 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BestWebSoft | Contact Form Plugin | 3.51 | — | No fix listed | CNA |
- Contact Form Plugin VendorBestWebSoft Affected 3.51 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bestwebsoft:contact_form:3.51:*:*:*:*:wordpress:*:* | 3.51 | Vulnerable | BestWebSoft |
- cpe:2.3:a:bestwebsoft:contact_form:3.51:*:*:*:*:wordpress:*:* Versions 3.51 Vulnerable ·BestWebSoft
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2013-10022
- 2026-10-03 Alias added: GHSA-jq78-35r2-82rh
References
More BestWebSoft Contact Form vulnerabilities
- TI-2017-14121 BestWebSoft Contact Form Plugin Stored cross site scriting CVSS 3.1MEDIUM 5.4
- TI-2012-05433 BestWebSoft Contact Form contact_form.php cntctfrm_settings_page cross-site request forgery CVSS 3.1HIGH 8.8
- TI-2017-13664 The contact-form-plugin plugin before 4.0.6 for WordPress has multiple XSS issues. CVSS 3.0MEDIUM 6.1
- TI-2017-01471 Cross-site scripting in BestWebSoft Captcha CVSS 3.0MEDIUM 6.1
- TI-2016-08907 The contact-form-plugin plugin before 4.0.2 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
- TI-2015-07672 The contact-form-plugin plugin before 3.96 for WordPress has XSS. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2013-10022 · CVE Program
- CVE-2013-10022 · NVD
- FIRST EPSS
- GHSA-jq78-35r2-82rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences